Starting Tips | Ask Questions | Introductions | Categories

VESC red blinking no firmware update possible no motor turn

I just started to work with my VESC two days ago. I used the windows BLDC tool. At first everything seemed nice. I soldered the wires and the capacitor to the board. Then I connected a 12V battery to start with low voltages. My computer could connect to the VESC (4.7) and I could upload the newest firmware. After uploading the newest firmware the VESC disconnected automatically. I just could reconnect it after shutting the VESC down and after powering it again I could get it connected to the BLDC tool again. But the firmware didn’t update at all. I repeated that step sometimes but I couldn’t get the VESC FW updated. It worked exactly like that every time. I think the bootloader is perhaps not flashed right. So I ordered a stlinkv2. Afterwards I connected my motor to the VESC and decided to start working with the BLDC Tool for FW 1.10. I read the configuration and Uploaded the configuration for the turnigy sk3 168kv. Afterwards I shut down the VESC again, then powered it up again. Connected it to the BLDC tool again. Read all values. They were stored and everything looked good. I wanted to start turning the motor. So I pressed the left button on the keyboard. The motor started turning and immediately stopped. The red LED immediately started flashing three times in a row. Then around a second pause and flashing three times again. That happens every time I repower my VESC. When looking at the Real time Data tab and enabling ‘activate sampling’ it gives back a fault code: DRV8302. Additionally I wonder why the Mosfet temp is 40°. I’m glad for every help :slight_smile:

It looks like you may have uploaded the firmware for version 4.10/4.11 hardware. Incorrect temp readings are a sure sign of this. Hopefully you did not burn a trace on the PCB. luckily you were only using 12v so the PCB is probably fine but you will need a new DRV8302 chip.

I always used the VESC_default.bin out of the folder hw_46_47. So never any FW for hw 4.1 or 4.11 Of Course I tried to upload the firmware 2.8. But I also tried to update to older versions for hw_46_47. And as I mentioned the BLDC Tool never succeded in updating the firmware. After reconnecting the BLDC Tool just recognizes FW 1.10. So it seems my DRV8302 already seemed to be broken when arriving? Does anybody think it looks like a change of the DRV8302 could solve all my problems?

here some pictures of my vesc: and here some screenshots of my bldc tool: (I just reduced some current limits for my motor) and here of the firmware tab:

The incorrect firmware update is probably what caused your failed DRV8302 chip. Incorrect settings will often lead to this failure.

As @chaka said, you should be able to get back up and running with a new DRV chip; props for using a power supply and not just a lipo!

As far as I read through the forum until now the failed firmware update is due to an improperly flashed bootloader. But the boards of others worked fine in the BLDC tool for FW 1.10. Even after failed FW updates. My board already had a hot MOSFET and immediately stopped turning the motor. I’m concerned that there is more wrong… (Compare to the thread I posted at first: Enertion vesc flashing pink light - failed motor detection DRV8302 error)
Did that VESC already arrive at you and you figured out the failure? I would guess perhaps my board has the same issues…
After these people flashed the Bootloader again they could update the FW and everything worked fine. At least I read it several times.
Ok I’ll see to get a new DRV8302 and find someone to solder it to the board for me. Afterwards I have to flash the bootloader and install the FW again? I don’t have ubuntu. Is there any possibility to flash the bootloader with windows and then install the firmware again?
Sorry what do you mean by: props for using a power supply and not just a lipo!
I didn’t use a power supply. I used a 12V car battery.
Do I need the DRV8302DCA or DRV8302DCAR chip?
I’ll try my best to get it working again. The new chip needs around 10 days to deliver. I hope if none of these steps is successful I can get a replacement VESC. I’ll keep you up to date on my repairing process.

The R stands just for reel and means the package they come with. So the IC is identical, so go with the cheaper one.

1 Like

So. Until now I didn’t replace my DRV8302. Still waiting for a new chip. I bought a stm32 discovery board and installed ubuntu on my computer. So I was able to successfully update the bootloader and the firmware. Afterwards the VESC also stopped blinking red. I have a turnigy aerodrive 149kv with the VESC. So I read in the mc_config Data for turnigy aerodrive 168kv. The difference between these Motors is not too huge. The Failt code also disappeared and my Mosfet is quite cool now :slight_smile: My problem now is that the Motor doesn’t turn at all when being connected to the BLDC Tool and hitting any up/down/left/right key… I tried the automatic Motor detection to get it turning. That also didn’t succeed in letting the Motor turn… It just says detection failed… Please Help.

Since it’s a red PCB: did you purchase this VESC in May/June last year? If so, it would be from the flier batch…

I ordered it the 13th July 2015. It arrived middle of September in Germany. I was studying abroad so I just returned and started working on it… The flier batch was mainly good or bad? Another strange thing is that the BLDC Tool shows a motor current of 0.7 Amps with a battery current of 0 Amp and the motor is not being turned…

The flier batch was faulty, that’s why Jason stopped working with them for esc’s.

Yours is definitely from the second batch (not flier) and this one is ok. I’m still driving that one myself and it works well. The bootloader was missing, so I uploaded it myself (like you did).

Did you check your capacitor if it is soldered well and working? Another try would be to adjust the detection parameters for the motor detection before hitting detect.

To be honest, I don’t think it makes much sense to use others motor values (the xml files), it’s always recommended to detect the correct values of a motor on your specific one.

I changed the motor values several times bevore hitting auto detection but it just gave back detection failed. I tried to increase the current until 10A and decrease the min ERPM until 150 but the motor wasn’t intereseted in anything and refused turning. When looking in the Realtime Data while the Auto detection worked the Battery current stayed at 0 and the motor current was mostly around 6 A and sometimes a little higher… I also increased low duty until 0.15

I only had the effects you are describing once, it turned out that it was related to a bad power connection. Can you try a detection again with another motor?

I’ll get another motor from a friend for testing in some days. But I’m not very optimistic…

this is the screenshot of 5A in the motor and no battery current … perhaps that helps somebody solving my issue?

rewired my power connection, checked that nothing is shorted, checked my capacitor and moved it really near the board but did’t solve the problem…
Pressing full brake button in BLDC tool also shows no effect… Thats strange because I thought full brake is just shortening all three phases… when physicly connecting the three phases motor is really hard to turn. When pressing full break in BLDC tool there is no difference in motor behavior…

Yesterday I recognized that some Pins of my DRV8302 are shortened. But never 2 Pins that are directly in use. Do some VESCs have some pins of the DRV8302 connected and they are still running? Is it sufficient to remove the connection between the pins? As the newest firmware doesn’t detect any DRV8302 failure code is it still necessary to change the DRV8302? As I haven’t been at that place with my soldering iron the VESC already arrived with shortened pins of the DRV8302…:S

Not sure if you have a short on the left, but if you do it’s not supposed to be there.

The 2 shorts on the right is perfectly normal. That should be documented somewhere in a faq

Yes I have and you’re right there shouldn’t be a short… So. Just returned from the university laboratory. I got help to disconnect the two shorted pins and measure all the chips on the board. Afterwards the motor controller still didn’t work. And it is very clear why. The connection connected the en_gate pin which can handle only up to 7 V with the cp2 charge pump pin. So the charge pump killed the en_gate pin and so the whole drv8302 and it also killed the pin of the CPU. The CPU can’t any longer set the en_gate high and perhaps even more broke. Clearly a production failure which caused the complete VESC to fail…! @carl.1 : Do you still want the messed up board back or will you just send a new one?

I would be super happy to get an answer from Enertion Boards to my warranty request… :blush:
Sorry for my impatience. Can’t wait to finally ride my ebike…