VESC shuts off when under load

Hey guys, I’m trying to figure out why my entire setup loses power whenever I am hard on the throttle. So far, I’ve replaced my vesc (FOCbox DRV fried so I replaced it with a Flipsky 6.6) and nothing changed. I also tried bypassing the BMS for discharge, and that didn’t solve the problem either. In addition, it seems as if the whole vesc loses power, so no fault codes are shown. Would this be an indication that my motor is causing the shutoffs? Before this started happening, I did drop the motor on the floor while I was tinkering with it, but I opened it up and did not see any signs of shorting.

Post some pictures of your wiring and setup.

Here are some images of the setup (it’s a bike!), and the wiring diagram that I made prior to starting the build.

And you tried shorting B- to P-, and it made no difference?

Yes, exactly. There was no change in the shutoffs after I made the B-/P- short.

I’ve got nothing.

If it’s a vesc issue, you should be able to get a fault reading out of it using the console.

If it’s a BMS issue, then bypassing should have fixed it.

If it’s a wiring or connector or battery issue, it should present as voltage sag, not an abrupt cutoff.

1 Like

The only thing I can think of is a bad motor? I dropped the motor from about 4ft onto the ground before these problems started happening, although I did not see any obvious damage.

My theory is that under high RPM & current, something from the motor causes my VESC to freak out and reboot, but I want to confirm if that is even a possibility before I spend any money on a replacement motor.

Even if it is damaged and causes vesc faults, it should still result in a fault code that you can read in the terminal.

I see. I’ll try to reproduce the shutdown again this weekend and double check the fault logs.

1 Like

maybe just try updating firmware and redoing your motor detection? that may help?

Hi RedLiquid,

I had the same on my Mountainboard. I’ve setup my battery, motor and VESC that it can deliver over 60 Amps by 42V. After a while on high load my motors stopped. I know it can’t be the motor because both of them cut off so I measured the voltage during under load and I measured a significant voltage drop. Unfortunately the Vesc has quite a high voltage cut off default setting but during your configuration you can switch this feature off or set the cutoff voltage lower. In my case I’ve disabled this feature because my BMS is doing this already. Since then my Mountainboard drives very nice. Hope that helps

Hey guys I tried a few of your suggestions, but I’ve had no luck.

I tried reproducing the shutdown earlier today to check for fault codes, but there were no codes registered “since startup”. I believe the entire VESC powers down/reboots when I lose power, so every time the error occurs, any fault codes are erased from memory. I verified this by using the “Print Threads” command in vesc tool; it tells me that the vesc has only been awake for the duration after the shutoff. Right now it seems like a game of Schrodinger’s cat, because I don’t have any way to view the codes. : (

I tried this multiple times, but it doesn’t appear to change the odd behavior of the vesc.

I just checked, and I have my voltage cutoff set to 3.0v per cell, which seems to be the lowest value that anybody recommends. I have not tried to disable the cutoff feature entirely yet, but I believe if this was the issue, my fault log would show it?

Even if the low voltage cutoff is set too high and causing faults, the vesc hardware itself can operate down to like 12 volts, so unless you’re somehow dragging your battery voltage all the way down to <12v, the vesc should still remain powered. That’s what’s confusing me.

make sure your absolute max current setting is a lot higher than the motor and battery current setting limits and the low volt cutoff is properly set if that doesnt work try lowering the motor current limit setting and adjusting the temp cutoff settings

I was finally able to read some fault codes today, after testing the motor with no load. It says I have ABS_OVER_CURRENT, but I’m not sure which setting I need to change. I attached my fault code and vesc settings below.

Battery: 12s5p li-ion

Motor: Maytech 6374 190kv, 60A cont, 3550W max

VESC: Flipsky fsesc 6.6

Just got another fault code, this time showing a current spike of 217A (wtf!). Not sure what is causing the current to jump like that.


Well, that’s something at least. I would suggest trying to shorten your battery and motor wires as much as possible, as inductive current/voltage spikes can cause issues like this.

You might also try limiting your ERPM to ~60,000, and see if that affects things.

Update: got a new fault code. I repeated the same test, but this time I used my bike brake to simulate a heavy load. The vesc rebooted itself and this code popped up:

Also, I had my ERPM limited to 48000 already. (my motor emits a high pitched noise at >50000erpm) cap5

edit: Did some research on this code and it looks like it doesn’t really tell us anything other than the fact that the vesc has, in fact, rebooted. x_x

1 Like

try lowering your motor current limit setting

ps whats the bat voltage, kv and # of magnets in your motor. i don’t think you want the erpm limit set below what the motor will naturally do

1 Like

Will try that later today. Also really? I never knew the erpm shouldn’t be set too low. My battery is 12s, so 43.2v nominally. The motor is 190kv & 14 magnets. It naturally reaches 52000erpm but I had it limited to 48000.