VESC - static blue LED after bootloader upload with STLINKV2

Hey community,

I actually am really frustrated now, short overview of what happened:

  • got VESC (4.12 from HK) after an Car-ESC
  • set it up on a friends PC using BLDC-Tool
  • wanted to edit settings - downloaded VESC-Tool
  • did a firmware upgrade cause it said so (for 4.12 HW)
  • NO USB connection between PC and VESC possible anymore (static blue LED)
  • flashed bootloader with STLINKV2
  • VESC still cannot connect to PC (even installed STM32 drivers for windows again, allthough they worked previously)

I am really down right now, don’t have the money to get another VESC. Can someone help?

Best regards, Thomas

EDIT: USB-Cable is tested

I have the same issue. VESC stopped connecting. Blue led only. Flashed new bootloader with stlinkv2, no change in behavior. Any updates?

Try flashing the whole firmware with stlink, not just the bootloader. Boot loader only wouldnt work for me either.

Thanks. I figured that out eventually. Had to try several versions before it worked.