Vesc superfoc6.8 I lost ppm/pwm signal input. Is it possible to get it back by removing the can chip?

My vesc recently stop working with my RC receiver. And I suspect my can chip as the issues possibly. Is it possible to get the input/ppm back working with my RC. If I remove the can chip ? Everything on the vesc still works as normal. I can move the motor with my laptop just fine.But dead ppm/pwm and can bus appears to be all dead as well. Looking for cheap fix. Any advice would be appreciated.

1 Like

can you explain the correlation in your thinking between PWM and the CAN chip?

If you’re still getting remote signal into the vesc, run split PWM to each side, should work

1 Like

I assume they where connected some how been reading a lot of forums. If off please correct me. I have never had a issue with this vesc. I would like to find a solution with damaging this vesc.

I had a surge happen on-board from my dc to dc inverter. And somehow my ubec signal input stop working. 5v is still working tho. It will power a rc receiver.

I cant see signal in vesc tool mapping stuck on -100

I cant see any visual damage to the board. I can only make it move thru my laptop thru usb.

Did you check the settings to see if anything changed?

If the ppm output is dead, something got fried… Not sure otherwise since I rarely use the canbus myself nor had this happened.

I read that it could fix the issue. Im not 100% sure since i only seen a few say yes.


Yes everything in the settings was the same. I only tried to use can bus as a solution. And yes I believe something is fried. What chip could be fried?

I heard the same thing.

Probably this. If you have a multimeter you can check the 3.3v line and see if that is shorted. Im not an expert on this so I might not have more replies after this one. Hopefully someone else with more knowledge will assist.

1 Like

I believe it is because it took out the channel it was hooked up to.

Possibly. But as stated, I havent gotten this issue myself so i am not of help in this one. Hopefully you’ll find the answers quick.

Did you ever fix yours?

No gambling with removing the chip.

Never had to. I’ve only read about these issues by searching “canbus chip fried esk8” just incase I get to an issue. So far, only removing this fried chip fixes (or so I’ve read from 2 people) this issue and returns the pwm.

Here in DIY, you always have to gamble the outcome. But I wouldn’t do it unless I know for sure it will fix the issue.

I agree I did the same research myself. I tried to email those people. Especially that Johnny guy.

If you need more assistance, I could pm you another place you can try your luck at. But you would definitely need a disclaimer before proceeding.

I need all the help I. Can get lol

Sent. Check pm.

That disclaimer is super weird. :laughing:

1 Like