Vesc thinks I'm going double the speed that I'm actually going?


I installed a Metr Pro last week and when trying it out I was going super slow. I played around with profiles and came to the conclusion that I only had to change the max speed/ERPM to actually go faster or slower.

With GPS I know my top speed is 45km/h, while the Metr app shows ~90km/h. If I set the max speed to 50 with the Metr app, I’m only going 25km/h etc…

What would be the cause of this? I checked the gearing settings and wheel diameter and those are correct.

My setup is:

  • Flipsky Dual Vesc 6.6
  • 10S4P
  • TB 6355 190kv
  • 14T/36T
  • 90mm wheels
  • Running Sensored FOC mode
  • Both the Vesc and Metr are up-to-date

Any tips? Thanks in advance.

Ninja edit: Someone mentioned that it could be related to having a dual vesc?

Its because you have wrong settings in metr, go: Settings>Motor and select correct wheel size and gearing I suggest you also go to battery and choose correct Voltage your battery have.


Well, I think you are right. I remember setting it correctly but the gears were both on 1 instead of 14 and 36 but it probably didn’t save?

I hope this is the simple fix, I can test when I get back from work.

1 Like

Unfortunately that was not the fix. It still happens.

Dumb question maybe; under Settings>Magic I have “Dual data” turned on. Should that be on if I have a dual VESC instead of 2 seperate ones?

I think so, but best is to ask @rpasichnyk

What did you put for the setting “Motor poles”? It should be 14 for your motor

It is set to 14 poles indeed.

Turning off dual data did the trick, speed is normal now.

Thanks @mackann and @ARetardedPillow for your input.

1 Like