VESC-tool / Motor expert please look here

I’m assuming you are using FOC since you have vesc 6? screen dump after you run R/L/ flux linkage calibration. What is motor kV supposed to be? We could take a look at flux linkage measurement and compare it to your motor kV. If this value is wrong it could cause estimator to track poorly.

A screen recording of the realtime data screens while this phenomenon happens could also help. FOC tab might be most useful to see how FOC currents are tracking.

I might also suggest tuning the current controller time constant of your motor controller. I think by default it is 1000 us, try something like 2000-3000 us for less aggressive current controller gains.

Try BLDC also… if same phenomenon happens in FOC and BLDC, it is probably a mechanical issue with the motor.

1 Like

Does this happen in a single motor configuration with each motor? How about without the gears attached, just bare motor?

Also what others said, about trying it in BLDC mode, but try without sensors (is it sensored?). The idea is to see if the vibration happens with these different methods to rule out ESC issue.

Although it seems highly improbable that both motors have the same mechanical issue.

Oops, I actually didn’t read the part where you say you had this issue with both motors.

So you did actually spin up the motors -one at a time- and both motors make this noise?

Did you hear this from the very beginning or is this something that has appeared after a while with this setup?

Hi Guys

I tried in BLDC mode - No difference.

That let me to the conclusion that it must be an mechanical balancing fault. I tried balancing with different object just to try if it made any difference at all - No diffenrence :frowning:

Back to VESC6 Settings - Autodetect settings ends up like this:

The motor is this one:

RPM Video of the problem (Motor goes up to certain RPM level and then vibrates even harder if i turn up the trottle, until it “breaks through” and gets above the vibration RPM zone:

FOC video of the problem:

Current video:

I´m lost guys - Help med out here :slight_smile:

And again, motor is running free with no gears attached. VESC6, LIPO 12S

Did you try running in unsensored mode as I suggested earlier?

Yep - foc, bldc, sensored, unsensored e.g… :frowning:

Open up the motors and check for loose magnets or sign of magnets touching the stator.

I think I see metal shrapnel and likely an incompletely glued magnet

I know :slightly_smiling_face: I also thought that was the problem, so i took all magnets out today and 3d printet a guide for the other end (they are only guide at one side originally) and re-fixed all magnets totally aligned… And tada!!! No changes at all :frowning:


What did you use to repot the magnets?

:rofl::rofl::rofl::joy::joy::joy::sweat_smile::sweat_smile::sweat_smile: time for another oops. oh, so you did open up the motors already lol.

you have to excuse me… been sitting for 7 hours straight doing our final big exam. brain is messed up.

1 Like

Both motors are doing this at the exact same rpm range, with different vesc?

It seems highly unlikely that 2 motors would have the same exact mechanical defect and that both vesc would have same issue. So at this point perhaps they are incompatible :frowning:

I would say if bldc and foc both produce this resonance, it is probably a poorly designed motor? At some speeds motors can have mechanical resonance but ultimatley should be designed with resonance peaks far from the operating range.

Yeah I would send Bruno the vids of both motors exhibiting the problem and send them back.

Just try each motor without the other. Maybe you have traction control enabled.

1 Like

Also try the motors on a different ESC or the ESC on a different motor

Have the same problem with the same motor, together with Escape vesc…

To me it’s sounds like a motor timing issue, could it help to change the Hz… That is possible in @Ackmaniac firmware ?

This is a badass setup, what are we talking about? 16hp?

Feeling inadequate with 6374 here :snail:

Yes it is…

But not cool, when it sounds like this :-/

I am having the exact same issue with my 8072S (~65% RPM on a 12s). Did you ever find a solution?