VESC tool, motor not spinning (clicking/grinding)

I have a FSESC 7550 and a Torqueboards outrunner motor. I connected the two and ran the VESC setup, which worked fine (the motor spun up). Then, when I try to use the arrow keys to simulate throttle within the VESC tool, the motor makes electrical buzzing and clicking sounds and doesn’t spin. What can I change to make the motor work properly?

Here are videos of the issue. The first video shows what happens when I try to use the arrow keys to turn the motor, which buzzes and clicks instead of spinning. Automatic duty cycle ramp also causes the same issue:

The second video shows that, interestingly, when seeing which motors are inverted, the VESC tool spins up the motor properly.

I’ve tried setting up the motor both with the hall sensors connected and disconnected, and it causes the same behavior each time.

I solved the problem.

For the first case, to get the arrow keys working in the VESC tool, I went to the left sidebar App Settings → General → APP to Use → select “UART”. Mine was set to “PPM and UART”. Changing immediately gave me keyboard control of the motor, and the VX2 started working as well.

1 Like