VESC-X: Less range and a different voltage than battery

So here’s the story, I’ll try and explain everything in a list order so it might be easier to identify the problem:


  2. Soldered to 4x 3S lipo in series, and 5.5mm bullet connectors

  3. Setup in BLDC Tool Settings for step 3 setup: BLDC (no sensors Motor max 60 Motor min regen -40 Battery amp max 60 Overall max amps 130 Battery cutoff start: 44.4 Battery cutoff: 43.2

  4. Ride, board works flawlessly and goes 45kmh

  5. One phase wire comes loose, resolder.

  6. Configure in BLDC with sensors Speed goes down to around 25-30kmh

  7. Remove sensors leave on BLDC: speed still the same

Firmware reflash: default settings, enable FOC, now speed is 10kmh.

Any ideas what the problem could be? I will send screenshots later tonight and I will measure battery output voltage. Cells are at 3.91 each

Thanks guys, hope I can get this resolved quickly so I can start riding. I’m thinking it could be my battery voltage cutoffs? Should I try charging?

Whats the total voltage after your antispark switch?

Not using antispark switch. Just plugging straight into vesc. Waiting for some xt90s to come

Maybe because the Esc capacitors dont like The spark by connecting a 12s battery?

I’d still like to know to the actual voltage the VESC “sees”.

Once I have access to my laptop I’ll check it

Dont you have a multimeter at home? Its the most basic and cheapest debugging tool, lol.

IS it still possible for him to add bluetooth module? :smiley: Might as well just get better logging data… or course, multi meter also does not come pricy… mostly 5usd and you got yourself a voltmeter :smiley:

Sure, he can. But why BT when he can just connect the USB cable into the computer?

Also, multimeter is the most basic must-have thingie when working with electronics. They range from $10 to few hundred. I personally use mainstream $30 one.

@IDVert3X Of course I have a multi meter! I’m not at home right now, or at the workshop. So I don’t have access to any tools.

Any ideas? @ackmaniac @chaka ?

So I think I found the problem… the vesc is reading 43.2v into the vesc, which is where my cutoff is at. But all my lipo cells are at 3.95v per cell which is 47.4v. So why is there a difference of 4.2v?

Because your soldering is probably not good and you have some unwanted resistance somewhere. You mentioned you had to resolder your phase wire - that might be your starting point to redo.

Thanks @Maxid. I’ll recheck the soldering connections. I do have lots of plugs to wire the 4 batteries in series. Could I lower my cutoff rate to work with the battery voltages?

There is something wrong with your batteries - fix it first before you start using it again. The “missing” voltage is being used up somewhere and transformed to heat - you don’t want to ride like this.

Thanks so much man! I’ll resolder all connections that don’t look good tomorrow. Hopefully then the board will be working.

Better advice: take your multimeter, switch on the board, measure voltages across connections. They should be very close to zero. If there is a voltage, it means there is a voltage drop because of resistance, then you know you need to resolder it. And remember, the higher the current, the higher the voltage drop will be.

Another way is to keep the board shutted down and measure the resistance using the multimeter. It should be close to zero as well. This is the safer way, but will drain your multimeter battery more quickly.

If neither of these shows any signs of error, come back and we can discuss it further.


So the issues could be one of two things: A wrong resistor on the vesc (I am speaking to Charles from Enertion and @JohnnyMeduse about the issue

Or bad soldering

I will be able to confirm the final issue today. I would also highly recommend that anyone else who feels like their cutoff is getting activated sooner than usual to check the voltage from battery directly (with multimeter) and check the voltage on your BLDC tool. If there is a difference, there could be a wrong resistor on your vesc x.

Have you tried reading the voltage with all 4 lipos in series but without the vesc? to see if the vesc is reading wrong or if the cells are really trhat low

Haven’t got my good multimeter. The one at home is my grandpa’s one. It’s super crap