VESCs BLDC tool - what's the current version? Where to download? Confused!

I’m trying to figure out what to do with these shiny new VESCs I got from @onloop a couple of weeks ago. My board is nearly ready, so in the next few days I’ll be connecting the electronics and configuring this dual Ollin 170kv motor Enertion VESC 8S setup.

But I tried to download the latest BLDC tool, and things are getting weird. Looks like the tool is mid re-locate or something? The links I followed didn’t get anywhere, or got to which didn’t allow me to download the current version for OS X or Windows, even after the forced sign up to their mailing list next to all the misspelt donation buttons. (I’d happily pay BTW, but not forced before-hand I don’t know what I’m getting, let me donate afterwards).

I did manage to find the OS X version of the tool by navigating through their file structure (always disable indexing in your webserver config). The app I got works, and I’m not sure on the version, but it only supports firmware versions 2.17 and 2.18.

So that is the next problem. The tool comes with a bunch of firmwares for different hardware, how do you know which hardware your VESC has? I see this:

1 Like

You’ll need the one in hw_410_411_412: VESC_default.bin.

Hardware Version of your VESC is printed on the PCB and it’s 4.12 currently.

So it was, thanks :slight_smile: that’s part of the problem solved

latest firmware: latest BLDCTool:

Explanation on how to compile the software:


Thanks, I would prefer to use OS X, and that didn’t look to be an easy option from source. I’m pretty sure that the version I found is correct, however I thought I’d see if I could compile it myself from source too.

It was actually very easy, I just downloaded and installed Qt from the Qt site, then ran qmake and make and now I have an OS X BLDC tool from source. So that’s definitely an option. Haven’t succeeded in building the firmware yet, but that’s not really necessary.

1 Like

Did you blow a fet? In the picture your middle fet seems damaged

I noticed that too, inspected the VESC and it’s just a bubble in the heat shrink :slight_smile: