Vx2 UART Throttle curve settings?

Anyone know how the heck to adjust the throttle curve please? I’ve just upgraded my ESC and motors. I’m running VX2 controller, Flip6.6 pro and 2 X Flip 6384s. Everything’s working fine, loads of power but feels a bit slow off the mark. I’d like to boost it up a little to get better acceleration but can’t figure out how. Via Bluetooth I’ve tried the APP CFG tab and UART. There’s no throttle settings in there. Go to PPM or VESC Remote there’s a throttle curve tab BUT if I change it in either of them it messes up and only one wheel spins up. Anyone know how the heck to adjust the throttle curve please?

1 Like

As far as I know. UART doesn’t have its own throttle curve, you may have to change ramping time instead. Its not the best fix though.

So many vx2 problems…

1 Like

VX2 throttle curve SOLVED Well it seems there is a way to change the throttle curve using the VX2 remote. Here’s my understanding of it, this worked for me!

Following a chat with the very knowledgeable Stuart over at ATB Shop in the UK I now have it working with my Flipsky dual 6 vesc.

Using Bluetooth connection and vesctool 3.1 Once you’ve setup using Motor CFG do a backup of your settings using vesctool. Then you can restore them if the below messesu up our rig.

NB, your vesc’s will have individual numbers, I’ll refer to them as A & B for this work through. if the remote receiver module is connected to vesc A and the BT module is on vesc B then your master vesc is A when riding the board and B is slave over canbus.

When you connect to BT via vesc tool then B is the master/local vesc. Change settings on this side will just screw things up. You must “scan can” in the vesctool app and select vesc A (master vesc when riding, it’s the one that doesn’t say “Local” on it when using the BT module).

In vesc tool go to APP CFG screen, select VESC Remote then underneath comes a throttle curve tab. Boost it up by 20% worked nice for me (rocket ship😎) ***Only change these settings once you’re sure you’re on the Master vesc side NOT the one shown as Local vesc when using Vesctool over Bluetooth! You only need to change the settings on the one (master vesc A) side when using APPCFG, unlike when using MOROR CFG where both sides need to be the same. ***

I hope this helps. Many thanks to Stuart at ATB Shop for his help and support.

Stay alive people, never ride without a helmet and protection. I’d be dead now…:skull_and_crossbones:


Thank you for coming back to share the solution.

1 Like