Wanna hear a weird VESC problem? CLICK HERE

So I just finished turning my 6S Lipo board into a 6S2P Lipo board and I was stoked to give it a shot! So I plugged that sucker into the computer, ran a motor detect and hopped on it for a quick test ride. After riding around I decided I wanted more glue on my enclosure… (my enclosure looks a lil something like this…)

And so after painstakingly waiting the 48 hours for the glue to cure I hopped on the board. Stoked for another test ride. BUT IT WAS NOT GOING TO HAPPEN. My board was at full brake without touching the remote and the only way to get the motor to spin at all was at full throttle where the wheel was only going about 2 mph. Something was wrong .

So I ran upstairs and plugged the sucker into the computer, ran a motor detection and thought… well everything seems in order. But when I used the arrow keys just so spin the motor (for shits and giggles) the motor just twitched… So I panicked and checked for faults, zip, zilch, nada .

I went back and ran a motor test again, it worked perfectly.

Tried the arrows, nothing.

Check the lil’ real time plot, nothing happening, no current and just a wee little negative erpm when I hit a button.

So naturally, I get pissed and start pressing all the arrow keys a bunch and the motor is just twitching a lil’ bit, like a paraplegic who just managed to wiggle their big toe, (it’s moving but just barely) Then I hear/see what every esk8 member dread a quiet pop aaaaaand red flashing light. I thought I was hosed. I go to check what the error code is and before I can do it the motor starts spinning on its own.

WTF It rocked a little bit backward, then a little bit forward about 5 times. Then it went FULL THROTTLE without me touching anything I mean nothing. The wireless remote was off and both hands were off the keyboard of my computer and this motor is going fast as hell. So I unplug the power and the motor stops. I plug it back in and run a motor detection, no issues. I press the arrows, slight twitch. I then replicated the failure by mashing the arrow for a few seconds and I hear the pop and red light flash. Here is my error code and settings:

I would really love some input here as I am completely lost as to WTF is wrong with my setup: Why does motor detection work fine? Why does the motor work for a few seconds then full brake? Why am I getting an over current fault? Please send halp.

Hey, what firmware are you using? Can you take a screenshot of your advanced tab in the motor config? Also sometimes if you do your motor detection and have set PPM instead of No app it can mess with the results but I dont think that is your problem. Also do your motor detection without motor connected to the wheel. What happens if you hold an arrow key and “help the motor spin” with your hand? Does it spin up or not at all? Check your solder joints on motor connectors and on the VESC itself where the 3 phase wires connect to it.

1 Like

Hmm, try lowering your motor max and see if it helps.

here are my advanced settings

Is it what you have set in the VESC? because it is showing that it is not connected… just to make sure :smiley:

Did you try to spin up the motor with hand as i said before?

Ok go to the “App configuration” Tab and then on the left in the General Tab select “No app” and write the configuration. Now try to use the arrow keys. When this works then you first have to check your remote, adjust the failsafe and chosse the right settings in the PPM Tab.


Ok. I’m still at work but I’ll give these a try soon and update. As far as the not connected that’s because I took the screenshot while the board was off.

so i had soemthing similar to this happen, somehow i lost my ppm settings… did a remote calibration and now im back on… it would go full throttle just like you said until i changed the min pulse-width… with the default programming it thought i was already gunning it… hope you get it fixed gl bro!

@Ackmaniac 's solution worked. But I am unsure how to adjust the fail safe and PPM settings. I will look in other threads, but if anyone sees this before I delete this comment and knows where a good link / what to do and how to share it would be much appreciated!

Thanks for all the help!

***UPDATE: So I’m pretty sure the problem lies in the receiver. It isn’t connecting to the remote at all now. (Nano-X) anyway I am going camping tomorrow but will pick up a servo wire and do some testing. Will update on Saturday. This could be a much easier fix than I had hoped! Cheers

The error you got means your throwing a fault due to too high of a voltage, likely because your input voltage is above your vesc’s max voltage. This would then lead the motor detection to work, but it would try to spin, and fail because the second it tries, it throws a warning and boom!

Could you post the main vesc settings again and post the voltage of your pack?

It’s a 6S pack max voltage at default 57 volts

Oh and it’s the VESC-X (I got it right before the rename)

So weird, that’s what it means, but if it’s at 57, then idk…

Sure it’s not current? the first thing it says is that somehow it hit 150ish amps

Update* so I know that the problem likely lies in the receiver, as the light flashes once then does not keep flashing. Has anyone else ever had this problem/know a way to fix it besides replacing parts?

I had something similar and I want to say I was the connection from the vesc to the wires for the receiver, I replaced the wires and solved my problem.

Measure your 5v out when the receiver is connected and ensure that it stays stable and does not drop.