Weak Motor or VESC Issue?

Hi. Posted this on my build thread but got no views there. Apologies for repost here. Board has been running great for most part but am getting an oscillation in right motor wheel as I speed up. I think it has to do with one motor becoming weaker than the other at lower rpms. Left motor is easier to stop by hand when at lower rpms. At higher rpms, seems to be fine. Right motor is hard to stop by hand at almost any rpm. The video below shows this. VESCs have not been changed since initial setup. They both have exact same settings. Any ideas? Do you think it’s a motor issue or VESC issue? Or something else. Trying to figure out if I need a new motor. Thanks in advance.

this is a weird one… :thinking:

did you check your connections? Can you make the motor can wobble by hand? could be lose…

Hi. Motor can seems good as do bearings. No wobble. Haven’t checked connections but my guess is they are okay since the motor seems okay at higher rpms. Not sure though. Might have to see how things look using a voltmeter and compare both outputs on each VESC. THanks

@bill_f did you figure out what was causing this? Im having a very similar problem.

No. Haven’t figured it out. My guess is that it’s a motor issue. Bought a new motor. Waiting for it to arrive. Will post what I find out once I swap the motor.

Hi. So I went and bought a new motor and plugged it in. Same problem. Which makes me think, it has something to do with the VESC, or maybe a bad connection somewhere.

Both VESCS are the same brand with same settings. I’ve never changed settings since first config.

Has anyone experienced one VESC delivering less power than the other?

How would I measure the voltage being supplied to the motor being that there are three wires leading to the BLDC motor?

@TURNROCK Did you manage to solve your similar issue?

Thanks in advance.

How are the VESCs connected? I believe this is something to do with traction control, or a problem with your master-slave configuration. I run a single drive so I couldn’t tell you much about what the config should be, but I think that’s the best place to start.

Hi. Thanks for the suggestion. Each VESC is actually connected through a Y splitter, so each is getting the exact same signal. I haven’t set up traction control or anything like that. I’m thinking it’s a VESC issue. Or maybe there is a weak connection somewhere in the circuit. I need to take a look at solder joints.

post a screenshot of your vesc settings

reconfig both vescs. then if it still happens. switch motors/vesc to see if its the motor or vesc. if its the vesc/connection the opposite motor will have the problem. other wise its the motor…

1 Like

Hi. Has to be the VESC. I put a new motor on it and the same thing happens. Just checked settings on both VESCs in the BLDC tool. All looks okay. Can’t figure it out. Thanks

So I keep trying to figure this one out. Not so sure it’s the VESCs now. I checked both VESCs and the settings are where they are supposed to be. Ran motor detection with BLDC tool and all checks out. One thing I did notice is that with the diyElectricSkateboard VESCs, the arrow keys do not make the motors move while connected to the BLDC tool (just clicking sound) but with the Ollins, they do move. Not sure what that means.

After riding for a while, I get the oscillations, like one motor is pulling harder than the other. This time, I stopped riding and would roll the board and I noticed that the motor (motors?) are cogging (making a sound and feeling “sticky”). I would roll the board a little more and then lift it off the ground to allow the wheels to spin at full throttle for a few seconds. Problem disappears (until it starts again after a few minutes of riding). The problem seems to happen more often as the ride progresses.

Any ideas?

we still don´t have screenshots to help you out…

Hi. Here are a few. Stock settings except for what says (in his video) need changing. Been running these settings for ever. Problem started with same settings. And continue. Ridable but annoying. thx

Mine from DIY respond to the arrow keys. Super weird. Have you tried swapping VESCs and motors yet to confirm that it’s a problem with one of the VESCs?

I’ve used an Ollin VESC with the same motor and the arrow keys worked. With the DiY, it only makes a clicking sound and does not turn the motor. Same version VESCs with same settings on same BLDC tool. Otherwise, the DIY VESCs seem to be working okay (unless they are causing the original issue, but I’m not sure they are or if it’s a motor issue). Will swap both motors for two new ones and see what happens.

So it turns out it was one of the VESCs (diyelectricskateboard). I noticed that on the bad VESC, the LED would not light up when it got a throttle signal from the TX. The good one would light up. On both, the LEDs would blink on boot-up so I knew the LEDS on both were okay. Not sure what the issue is with the bad VESC. It runs, but does not seem to provide enough power at low rpms. At high rpms, seems okay. As mentioned above, when connected to BLDC tool, the arrow keys would not control motor–only makes clicking sounds. Wrote to diyelectricskateboard about repairing VESC (I’d pay) but have gotten no response. Any ideas on repairing this VESC or any ideas on what might be the issue with it? I’m now using two Ollin VESCs and it’s smooth like butter.

1 Like

I’m having a similar problem when using the arrow keys. Motor detection works fine, but when I use the arrow keys the motors just click. I don’t know why the arrow keys don’t work. My setup is: 10s4p Dual RSPEC Enersion 190kv motors VESC-6 boards Nano-X controller BLDC mode I also get cogging and then the motors screech unless I kick off, which didn’t happen on the 4.12 boards I used to run. But I hear this is a problem in BLDC mode. Any advice?

Never figured it out. Ended up switching my VESCs. Never heard back from so never got it repaired. Had the Olin VESCs so just switched them out. Ollins are still working great.

1 Like

I was having a very similar issue! Took motor apart and everything was fine, VESC and programming/ everything also fine but my issue started happening after I got a rock stuck in my motor pulley. This made me think it was something mechanical. Turns out my fix was the set screws from the motor body (don’t know correct terminology) that hold the motor body to the inner shaft came loose! Reinstalled with Loctite and good to go! (I know your problem was different just figured this might help others) cheers! :beers: