Weird Focbox problem? Video included


I was hoping someone on the forums might be able to help me with a problem I am experiencing with one of my focbox’s.

Originally the problem I had was a drv fault, I got that repaired locally and ever since then when plugged in the focbox does the below, it is also not being recognized via usb:

I contacted Enertion support who suggested that the problem was with caused by the FOCBOX missing the bootloader, so I’ve followed this tutorial combined with information in this thread about the port differences which seemed to all work well. The last information from the ST-Link Utility was:

13:41:02 : [BLDC_4_Bootloader.hex] opened successfully. Address Ranges [0x080E0000 0x080E01AC] [0x080E01B0 0x080E10A0] 13:41:02 : [BLDC_4_Bootloader.hex] checksum : 0x00055E07 13:41:46 : Memory programmed in 3s and 438ms. 13:41:46 : Verification…OK 13:41:46 : Programmed memory Checksum: 0x00055E07 13:42:30 : Disconnected from device.

But this hasn’t changed the behavior, when powered I still get the weird light pattern and it is not recognized via USB.

It’s worth noting that all 3 status LED’s are lighting up when connected via ST-LINK so they are working fine.

Does anyone have any idea what’s going wrong with the FOCBOX and how I might be able to fix it?

Thanks in advance, Liam

You wouldn’t have happened to upgrade the firmware via tcp at anytime have you ?

I have tinkered with some settings with the ackmaniac phone app via bluetooth, but haven’t changed the firmware.

After uploading the bootloader, did you also upload the firmware.bin file via the st-link? If not, you have to before proceeding.

Thanks for the suggestion, I’m struggling to find a .bin for the firmware. Could you point me in the right direction?

Thank you! Unfortunately I get the same result…

Did you connect the pins like shown here?

I used this wiring diagram

You only need 3 pins (DIO - GND - CLK) as long as you power the vesc with your battery

I wasn’t powering with my battery, only via st-link would that make a difference?

No idea. I read here it can blow up the 3.3V regulator on the VESC6 so decided not to risk it even in 4.12HW

@TrainRider Have you tried plugging it to the battery and then use ST-Link to flash firmware?

Just tried this, it doesn’t appear to be getting power and isn’t being recognized by USB. Seeing as it was working when being powered by the ST link I assume this means I have a problem with the 3.3V power on the FOCBOX?

1 Like

@TrainRider Double confirm your drivers and USB cable, also check if your FOCBOX’s MCU chip survived

How do I check the MCU survived?

@TrainRider Use multimeter to do that

1 Like