Weird VESC programming issue. Help?

I bought a VESC from DIY, connected it just the like the YouTube tutorial but I never get a usable port. Any ideas?

Btw, I’ve tried it in 2 PC’s with 2 different USB cables. Alli get is a blue light with a rapid blink, not the multi-color lights I expected. Any help would be greatly appreciated. Thanks

Is everything connected, the motor and battery? Also, if everything is connected, try a different cord. I have had unusable USB cords before, maybe that’s the issue…

Yep, motor and battery pack are connected. I tried a different cable as well. It’s a 6s battery pack, could that be the issue?

If you’ve had the issues across known working USB cables my guess is the bootloader. Issues like this seem to always lead back to a missing/bad bootloader. Which tutorial are you following exactly?

WEIRD, the blue light is suppose to be the Power… except if they change the placement do you have any video of the booting (what the led does when you plug the power)

I’m.using the DIY tutorial here…

But I’ve done tons of reading g and watching, trying g to get familiar as this is my 1st VESC.

I don’t, and I left it at work so I can’t get it right now…but I will post some 1st thing in the morning. But for real, it’s just a rapid blue light.

If the blue light it at the same place as the other one (the one in your video), and is blinking you might have a hardware issue with you VESC

I had that issue, spent a lot of time on boot loader etc. Then tried another USB cable and it worked, USB with power and data.

Have you got the latest VESC version from DIY? 4.12?

Hope you find the fix, please keep us posted as I got the same vesc yesterday and would like to know if I’ll have the same issues

I think Ive isolated this down to a battery issue. frikkin zippy’s are gonna drive me to drinking. Ill update when I get a new pack in.

Batteries shouldn’t have any effect on connecting via USB as long as they’re at some minimal voltage (5-6V I think). You could literally power the VESC enough to connect to USB with a couple AA batties (try 5 in series?)

If the power fluctuate, the vesc might not be able to boot properly


@mmaner what did you do to determine that it was the zippy’s? Have you tried watching the battery voltage with a multi-meter when you attempt to turn on the vesc and connect to it?

Ive got 1 cell that will not balance in a series pack. Its below the minimum so I think the VESC is defaulting to auto-cutoff.

Unless it’s really low, the vesc won’t cutoff for USB connections. The low voltage cutoff is to cutoff the motors.

However if you’ve got a LiPo pack that isn’t balancing correctly I would definitely replace it.

I’m trying to find a decent battery now, but the only ones available immediately are pretty pricey. I might end up getting a couple of new Zippy’s to get through to the new year.

yep, it was the battery pack. I found a good 5k mAh 3s lipo and it kicks right off. frikkin zippys…