What could be causing this motor to skip?

Not sure why, but upon doing a motor detection I can’t get this one motor to detect.


increase amps from 5 to 10 and try again.

Not going to lie. If the motor is securely mounted, id detect with the full amperage your going to use to get the most exact detection.

Its not the amps, increase the duty cycle(D) from 0.05 to 0.15

Are your settings in BLDC or FOC? My Vescs didn’t detect the motors until I discovered that my setting was on FOC rather than BLDC!


1 Like

I havent been using BLDC tool. Some guys yesterday suggested I try ACKMANIAC’s ESC tool so I’ve been running bench tests using the ESC tool not BLDC tool. There should be an option to switch to FOC on ESC tool. Let me check.

@ARetardedPillow I think you’re suggestion worked increasing the duty cycle to 0.15. BUT for whatever reason, now the damn thing sputters at roughly 15% duty in the negative x direction. Imma bout to throw the thing out the window :sweat_smile:

UPDATE: Never mind @anon42702729 got it. Just switching to FOC made it work like a charm. Not sure why but its functioning as it should now.

Get a hammer, more fun :grinning:.

Power everything down, reset to defaults and retry detection in bldc 1st, when that’s successful then try FOC. If it doesn’t work increase the sure cycle to . 1. Over that and your risking the VESC in the bench.


@mmaner Thank you for the advice! Apparently FOC has it functioning at the moment.

1 Like