Wheel pulley rubbing motor mount Problem

So I ordered this kit from DIYEboard.com:


Seemed like a good deal and with simple SS parts would be a nice power train. I have a Meepo and it works great so I thought the manufacturer would be a solid discount choice for a first time builder.

So I ordered the kit and after a bunch of conversations with Jason got some of their motors as well. The kit came in, I was super excited and put it all together:

I made sure to put the motor mounts on as far as the machining on the truck would let me and used locktite on the lockscrews to prevent torque twist. When I put the wheel pulley on and mounted it to the truck I noticed a light rubbing between the motor mount and the wheel pulley.

I didn’t think it would matter, it was very light, and I thought it would smooth out with use. Once I got everything up and running and put a load on the system is when the light rubbing became a huge issue. The metal would catch and stick at speed and the was super dangerous. I jumped off and took it home and took it apart.

The first picture shows how the paint on the inside of the motor mount has all rubbed off from rubbing against wheel pulley. Everything runs smooth with the wheels off. I remounted the wheel pulleys multiple times and I can’t get the motor mount any further up the truck.

Am I doing something wrong? What can I do to fix this? Do I just have to grind down the motor mount?

Any help is appreciated. Still new at this stuff.

Your wheel pulley is on the wrong side of the wheel. That doesn’t seem to be the problem though but yeah

I tried both sides of the wheel just to be sure.

Well atleast in the picture it’s wrong, put it on the right way and take pics Also, did you try adding a couple spacers to the axle before you put on the wheel? Looks like just 1 on there now

Ill do that tommorow. The other side is on the right way. Both sides rub. One side doesnt have enough thread to add anymore spacers. Ill try that on the other side.

The thing with diy is nothing work perfectly the First time. Keep trying…

Then move the mount away from the axle

I was selling the same products for a long time, I know the exact problem of this.

what is the solution? Grinding motor mount? grinding wheel pulley?

I have had this exact problem. I solved it but putting some extra spacers onto te axle. If there isn’t enough thread just put the nut on the other way, so the nylon ring is on the inside that should give you a bit more room.( It doesn’t have to have all of the threads engaged as long as the nylon ring is engaged)


ty sir \ijnnbnn

The one I am selling don’t have this problem. how much you got from them?

I got this kit from DIYEboard.com. I need 4 spacers on one side to avoid the grinding.

So, why not contact the seller for help?


Dude thank you so much. This was the only solution that worked.

As far as moving the motor mount in further, I wish I could but the kit is machined to fit to a certain spot and no farther. The tolerance was off by about 4 speed rings(A LOT) on one side and 2-3 on the other. I thought It could be the wheel pulley but I barley have enough thread to put the bolts on as it is and have to use the backwards trick.

I got it all working though. Thanks for the help everyone.

No problem I did that too but had to put two spacers on