When does the Bestech 80A BMS do its final balancing?

As the title suggests, could someone clear this up for me please.

My problem is that after charging to 100% and getting the green light on the brick charger the board will run OK for about 2 miles and them suffer compete shutdowns. Board needs to be turned off/on to power up again and then might be ok for a minute or two before shutting down again. This gets progressively worse until you can’t apply any throttle without it shutting down. By 85% it’s unusable.

Battery is 10s5p.

The thoughts are that a p group is unbalanced due to the battery being stored over winter for 5 months. The unbalanced group causing the BMS to shut down ?

I’ve charged to 100% and left on ‘green’ for 20 mins. Should this be longer to allow BMS to do its thing?

Does the charger need to be connected and board be ON for the BMS to balance ? Or does the BMS balance whilst OFF ?

Can’t find a definitive answer in the search function, or by googling. Has anyone else suffered this?

Thanks, Tony

1 Like

You need to check how much the P groups drifted apart. To my knowledge BMS’s can only balance differences in the 0.05V range.
For me it sounds more like you have dead cells. My smart BMS starts balancing before the light turns green. I don’t know how your BMS is doing this.

1 Like

thanks, how do you go about checking the P Groups exactly ? Is it from the balance lead JST plug (for +ve) and placing the -ve probe of multimeter one a ground terminal on BMS ?

As the battery is well used, if I have dead cells what’s the prognosis ? I’ve read that you shouldn’t mix old and new cells, so therefore can’t simply replace a dead cell with a new one ? Also since I’m not a battery builder, having never done any spot welding in my life to date, I don’t think I could safely fix my pack even if this were possible.

Could my whole pack be screwed then ?

1 Like

e6d3821d1e8c5beff61e44fb1fff1895808a4d4e_2_708x1000

I’ve literally watched each of my cells charging with a cell tester with that exact bms. once one cell hits 4.00v, it sorta stays there and the rest catch up slowly and end up at 4.18v each when full. also o don’t remember where but i believe it was that it begins balancing at 4v/cell.

take your balance leads out and measure from 1-2, 2-3, 3-4, 4-5 etc along the pack. if there is a large discrepancy between cell voltage then you’ve got a dead cell on that p group

2 Likes

thanks for the info ! Can I ask where excatly you are placing the multimeter probes to get the readings please. Is it from the JST plug (+ve probe) with the -ve probe placed where ?

there on the balance leads

1 Like

Screenshot_20190510-162556_Chrome

2 Likes

Thanks, that’s helpful ! Since I couldn’t get my multimeter probes into this plug (probes too big) I propose to use this : p to make it easier to get the readings.

This is my exact BMS: BMS%2080A

1 Like

That would work, but I wouldn’t recommend it as it’s super easy to short something when the probes touch each other accidentally. You could make an extension tip for your probes out of thin solid wire and take off the Isolation only on the ends a bit.

4 Likes

As you probably have a bad p group I would be stripping off the shrink and taking a look. Those bms’s are a good unit. What battery is it?

1 Like

yeah they’re almost the exact same pcb

@Andy87 yeah I had planned on soldering different length wires onto this header plug so that it’s impossible to get a short when testing. Something I could then keep for use again in the future if I need to test the p groups.

@dareno I’ve got the shrink off and can see where I need to get to. Just what are my options if I do find a group that is bad ? Is the whole pack toast then ?

I made an adapter for my lipos with this connector. It’s super easy to measure than on the terminals of that clamp.

image

2 Likes

can’t beleive I didn’t think of this ! Of course it’s far easier to buy a 11pin jst plug with the wires attached already and then do what you’ve done with the big plastic wire connector !

Sometimes I can’t believe how thick I am :blush: haha !

1 Like

Exactly what I did. Just for 7pin jst. Easy peasy :joy:

2 Likes

Yes, this is a big possibility and if so you are charging the rest of the p groups to overcharge, but that would force the balance function to engage and bleed the excess off. Are you discharging through the bms? If so, and your escs are drawing more than 80a it will cause cutouts.

2 Likes

If you find the group or in some cases the one cell it can be replaced, but you have to prime the replacement to do so. If the rest of the cells or groups are 3.8v then you must match this voltage to add it and keep balance.

Examine every group and test each cell, look for the lowest volt group. once you test each group by the count up method you should find something out of place.

an easy way to test each group without all the extra wiring would be to attach your negative probe from meter to negative (small jumper spring loaded) and use the positive probe with a point to probe the JST connector, You have to be careful to probe strieght up and down to avoid contact with two. It works well and you only need to do some math to find if a group or groups are out of balance or low voltage.

1 Like

I am discharging through the BMS but he Unity was set to the default 50A Max Min. I tried to lowering this but the cut outs continued. The thing worked perfectly fine for about 2 or 3 miles, scary fast as it happened, but buy 90% charge the cut outs started, and got more fequent (close together). By 85% the cut outs were immediate and therefore required a walk home !

The thing is, even if I find a bad group or cell(s) I just don’t have any experience in fixing li-ion batteries. Never done spot welding, and also don’t have equipment for charging single cells. Looks like I have a steep learning curve ahead of me…!

Well, if It can be a few things, have you updated the FW on the unity and adjusted the thermal throttling? Look for a loose solder joint in a connector T60 or T90. if all that checks out then I would consider the bad cell/group or bms, that tank may be the cause of the problem.

if all else fails you can send it to us for repairs

1 Like

thanks, that’s loads of info and hopefully useful pointers for me to investigate tonight on the bench. I did update the FW on unity before anything, but not considered the thermal throttling. It wasn’t the unity that was cutting out though, it was the BMS. That required a turn OFF/ON to reset. I have checked all connections first and they seem fine, but will go through them again tonight to be sure.

Whilst it was working there was no hint of poor performance at all. In fact it felt as fast and powerful as ever. I’m hoping that it’s the BMS, and can just replace that with a charge only version, discharging direct into Unity. That would be the ideal solution, but need to check the P groups are fine first of course.

1 Like