Works fine, then DRV error, then fine again

As the title says, i have a DRV problem. This video says it all:

I just recently got these two vescs, but one of them has been acting weird. This is not my first build so i kinda know what i’m doing.

Anyway one of the vescs goes in to DRV error for a second. It has happend since i got it. I have done a test ride and the board has worked really well, but as said, the vesc acted weird even before that.

It don’t know what’s causing it. Any help?

likely defective

Like jinra said, probably defective. Either replace the DRV, or replace the vesc.

@abctheing could you post the setting on both of the FocBox, these issue are usually due a bad motor detect or a duplication of the motor detection parameter on the Focbox… I doubt it’s a DRV issue, most likely to be a bad connection over the mosfet or a damage Capacitor, maybe you could post some picture of your setup connection (we are here to judge your skill but to help you) and some of the Focbox.

Regards JF

here are some screenshots. tell me if you need more

I’m not really sure, but if you look at the second Image, it doesn’t look like the sesors table as been properly apply

Ah the motor detection is from the second vesc. I reran detection for both vescs.

OK, but just make sure that the Parameter you’ve got from running a motor detection Sensors, integrated limits and coupling correspond to each motor in each vesc

Nothing seems to work. It still cuts out with DRV error for a second then goes back to normal.

Is there anybody (preferably close to norway) who could repair the vesc?

Are you running Via Can or split ppm. Try running can could be a connection issue

I am running split ppm. i also borrowed an older focbox from a friend that has been working for months, but now it gives my ABS_current_overload. I was riding the board then it suddenly stopped by itself. this happened more and more often and now the motor won’t spin, it just clicks.

Sounds like the motor was shorted and then fried. I would try to reset my VESC to default settings. Make sure nothing got screwed up. Also, check your phase wires.

I took apart my motor and reassembled it, i think the board works fine now. I took a small test ride and it worked.

1 Like

Nice, make sure all of your phase wires are insulated so you don’t get a short from a bump or something

Oh sorry, i actually mixed this up. I replaced the vesc with another one, and i have problems with this one as well. ABS_over_current. I managed to fix it but the problem is back again after a test ride.

Can you post pics of all your wiring and connections, Some error logs will help too

After a week i finally think i found the problem. One of the motor wires are broken and loose connection sometimes. The motor is brand new so this is weird. I think i have to open the motor and solder on new motor wires. Btw i have dual 6374 motors

Soo the focbox is still broken. DRV error but the motor still spins up. Now my second vesc shows the same error. It can’t be the settings because when the first focbox broke i replaced it with a 6 month old focbox. The old focbox has been working for so long, but the new fails? I have two broken focboxes now :sob::sob::sob: i bought them in a group buy

Does anyone know what could be the issue? I get DRV error but the motor is spinning? I am boardless right now.