X-NANO sinc but wheels not move HELP!

Hello everyone … I need some help … I have my x-nano i sync it with the receiver that’s ok , my problem is when I press the trigger on the x-nano the wheels do not move … Enter BLDC-TOOL and change it in App Configuration by PPM and still do nothing … change and probe with all and the wheels do not move , HELP please … thank you in advance

try swapping the channel

  1. Make sure to check your Tx and Rx are they binded? and wiring.

  2. Check the voltage from VESC on your Rx connection and Motor. { If you have VESC-X, check if the green LED is active and responses to your controller when pressing it.}

If non of these work. Do this once > Reflash the firmware to stock and repeat step 1 to 2

If not, then the faulty on your vesc or controller

reflash the vesc? Little extreme given how many issues there has been this the nano x. I found I had to sync the damn thing on one channel, then swapped the connections and it worked. There was also this thread on binding issues

Unfortunately I also tried it and it did not work, and then I put the post, but thanks anyway

Ok I’m having the exact same problem. The controller definitely binds, i can see it on both the rx and tx. But no matter what I do the wheel won’t move. Any luck here?

I’m 99% sure the nano-x communicates via PPM, not UART. Are you saying when you move the trigger, the PPM gauge moves? How about pressing the left/right buttons on your keyboard?

Yeah, it does move. I had to set it to uart for the iPhone connect app thing. Is this the probable cause?

Change it to ppm and uart then restart the vesc and see if that works. If you change the app config you need to restart the vesc. Could be your issue

yeah I’d stick just to PPM at the moment, it’s more reliable than UART (especially in congested areas). Hope that fixes your problem!

None of this seems to be working. I’ll try some more tomorrow

The VESC is getting good voltage, the remote is connecting, it just seems that no power is going to the motor

does the motor move with the keyboard arrows? What’s your battery voltage? I’m pretty sure the VESC will still be powered on (even if it’s reached battery cutoff), but I’m not sure.

The motor moves with the keys, and the VESC is at the regular 41 volts. Is it possible I blew that DRV thing on the VESC?

uuuuhhhh unlikely. Go ahead and check out the DRV errors (keep in mind that the DRV errors reset when the VESC resets). VESC seems fine, you’re running at 10s? What’s the motor you’re using?

It’s hard to tell what’s going on, but double check your BLDC settings (specifically app config). PPM should be checked and you should be getting the PPM gauge movin’ around n stuff

Did you set up your control mode? As in current no reverse and write it to the vesc? Maybe the disabled box is checked.

The disabled box was checked, but when I changed it to current no reverse it still doesn’t work. And with current no reverse the arrow keys don’t work.

The ppm gauge is definetly moving perfectly. Just the motor won’t move with it.

I don’t know if this helps, but I’ll give you the whole backstory to how this started. I took off the enclosure to make some software upgrades; upgrading to FOC and adding the Perimetr software to change the settings over Bluetooth. After that the remote didn’t work.

So to bring all the symptoms together, the remote connects on both the rx and tx, and the ppm gauge moves. The voltage in the VESC is normal. When the disabled box is checked in control mode, the arrow keys can move the motor, but when current no reverse is checked, they can’t.