Xiaomi m365 changing bms

Hi, this is more like a e-scooter question, I hope someone can help me out.

I have a Xiaomi m365 scooter which doesn’t charge anymore. After a ride (I almost emptied the battery) I opened it and checked the voltages of the 10s3p battery. All looking good. I get 36 V over all 18650 batteries in series and 3.6 V on all 3p cells, however when this goes through the bms the output voltage is only 17V (this 17V goes to the controller board), so there is something wrong with the bms as this should be 36V (or 42V fully charged). In fact there are two LED’s that are supposed to blink on the bms but I don’t see anything blinking. I read in most cases there is a bad welding spot on the battery pack or a Z fuse has blowen, but it was not the case for me…

All the components on the bms are looking good. I checked both Z fuses and also the big components that are crucial for the power supply (some mosfets and Schottky diodes) but they seem to be ok. The only thing I found suspicious is the BMS chip (BQ7693003). I couldn’t touch it as it was very hot! I believe it is over 100 °C or in that range. I think this is not normal… That’s why I desoldered the red wire from the battery pack as I don’t want it to be hot all the time…

Buying some of these components (bms chip?) will take some time to arrive (from china) and I wouldn’t be sure if this will fix it. As I need a fast solution (I don’t have another escooter nor esk8 ready yet…) why not buying a bms and replacing it with the stock one?

My question: Do you think this will work? Xiaomi has a Firmware for the bluetooth board, the bms board and the controller board. I am not sure, if I change the bms will the system still run? I don’t care about using the app I just want to use the scooter for the next few weeks until I get a new one. What are your thoughts?


Hi ! I’ have the same issue described by you…where you able to find anything? tks!

No I didn’t find the time. But maybe we can try to fix it… Can you please describe precisely how you encountered this issue? Also, is the BMS chip (BQ7693003) hot in your case?

Please read this, you will find there very good information.

This here is the D9 schottky diode that I thought was causing the issue. With my multimeter (diode test mode) I tested if there is a shortage, and it was! The two red dots here are shorted:

After I desoldered this component I noticed that the pcb is designed that way… so xiaomi used a dual schottky diode to get 2*5A=10A… So this is probably not the component that is defective… I tested all three big mosfets and they seem to be OK too.


I am facing a similar issue. The battery control board seems to be completely dead but I can’t seem to find the faulty component. The cells are intact and they output 36V as they weren’t fully charged before the fault. Did you manage to find a solution yourself or does anyone know if you can actually order just the pcb from xiaomi? I wrote to their global service but no response so far.

Have you guys seen this https://youtu.be/9cdZOjROdBM

1 Like

yes I saw that video. This guy replaced his Z fuse, but in our case it’s unfortunately something else.

Sorry I didn’t find the time to investigate yet :frowning: You can’t order a pcb from xiaomi, you can only buy the full battery pack (that comes together with the bms).

Please remember that the Texas Instruments BQ76930 BMS chip is customized by Xiaomi. You can’t just fit another one - even if you have a rework station that will handle these delicate SMD chips.

95% of the time that you have 36v from the battery but only residual voltage from the BMS is because the BMS has switched off the power due to a perceived fault. Many will be aware of problems caused by one of the 11 cell monitoring connections being broken under vibration. Just because there is 36v from the battery does NOT mean that all the connections are intact. All of the monitoring and thermistor connections must be intact, too.

There are a few other common faults. I have one on the bench now where an amateur has tried to repair the BMS card and snapped the ribbon cable, breaking many of the monitoring connections. Not a lot I can do about this but the customer does have a working BMS board with nowhere to use it.

This here seems to be interesting (use google translate): http://wiki.myelectricscooter.org/fr/xiaomi_mijia/xiaomi_mijia_m365#remplacement_d_un_bms_xiaomi_par_un_bms_generique

I will order this bms: https://fr.aliexpress.com/item/Mayitr-1pc-10S-36V-37V-16A-Li-ion-Lithium-Battery-BMS-PCB-PCM-Suitable-For-Ebike/32825891301.html?spm=a2g0s.9042311.0.0.J8Sl6Q&aff_platform=link-c-tool&cpt=1527182218651&sk=rNJiaeI&aff_trace_key=47a1030d1525453ea49a538516f3db97-1527182218651-01665-rNJiaeI&terminal_id=a9dbdc5524fe4af9bce845a8df0d9086 and this motherboard: https://nerch.en.alibaba.com/product/60757014408-805536253/replacement_motherboard_for_xiaomi_mijia_m365_scooter_parts.html?spm=a2700.icbuShop.89.3.204e5876WcLOUR

Will try to fix it that way. You can’t use the xiaomi app but if it’s charging thats fine to me.

There are so many errors of fact in that wiki article that I’m not sure I would trust the instructions on using a generic BMS board. As indicated, this would need a special controller board that can operate without a data connection from the BMS. It’s not clear to me that the Nerch components have been re-engineered to cater for a generic BMS. The alibaba web site only claims that they are replacement parts and I would assume they are identical to the original Xiaomi parts

I hope it’s not the case, but you could be wasting your money that could be put towards a new battery assembly.

Good luck!

How about an open source BMS?

Using this for the past few weeks with 12S battery on the original M365 controller. Bought the BMS from here: https://www.lithiumbatterypcb.com/product/13s-48v-li-ion-battery-pcb-board-54-6v-lithium-bms-with-60a-discharge-current-for-electric-motorcycle-and-e-scooter-protection-2-2-3-2-2-2-2-2/ You don’t need the bluetooth and PC interface that comes with it.

1 Like

Hi there,

I have the same symptoms like yours. How did you solve the problem?

Could you help me please? My bms or ribbon cables are broken. Bms has only 4 red flashes. On that website you ordered from can we order one for the original xiaomi m365 batteries? Will that work and doesn’t have to activate it or do some firmware thingy?

For me there is no LED flashing at all, I haven’t find the solution. That’s way I decided to replace the whole mainboard and bms. Still waiting for my mainboard to arrive,I bought it at alibaba and the tracking is saying its still on its way, no new news since mid June though… I believe they lost it…

@BotoX where do you upload this custom firmware?

I had the same issue, only red LED blinking, 20v on BMS output. But everithing seems to be fine on BMS and battery. Finaly i found that it vas broken little black cable on secondary temperature sensor locatet on the battery. In my case no need to change BMS. Not yet :slight_smile:

So I ended up replacing the BMS with one from aliexpress and when I changed it it worked for a minute but than the LEDs stopped flashing again… Then I notied the ribbon cable is causing the problem that is connected to the batteries, probably just a loose connection. When I applied some pressure on the ribbon cable it worked again…

1 Like

So the BMS from Ali is working now?

1 Like

This one is working: https://de.aliexpress.com/item/New-Outer-Inner-Tube-Pneumatic-Tyre-Accessories-for-Xiaomi-Mijia-M365-Electric-Scooter-Tires-Tyres-8/32815889093.html?spm=a2g0s.9042311.0.0.27424c4dQtJ6q8