Xmatic - VESC iOS Bluetooth App

Hey guys. Long been inactive for a long time. I will be Coming back to active now. I will move over to esk8 news as that’s where most users are heading to.

1 Like

New thread can be found here.

Tried hooking up to my FocBox Bluetooth no connection? Is there something I need to do to make the connection? So my Xmatic app will work?

Ok just picked up the FocBox Bluetooth module And plugged it in But no connection to XMatic App? Do I need to plug in my FocBox tool and turn on that port?

Assuming it has power. it should be discoverable in xmatic.
after that if it fails to connect to vesc you may need to check that you have the uart enabled in vesc_tool.

  • “app to use” set to UART or PPM + UART depending on your setup.
  • and the UART baud rate set to match the dongle. ( usually 115200 or 9600 )

please take note:

1 Like

Tried logging into the ESK8 News and created account and won’t sent me email to confirm? I tried another email account same thing. Anyways I went to the unity UI tool turned on UART and used setting in my focbox 115200 Baud. Also had to do a firmware upgrade first and reset all the motor settings etc…count not connect to the Xmatic so after spending about 4 hrs going through all the unity Tool. Few days later was upgrading my I phone and seen the app under settings and decided to investigate. Clicked open and there it was Bluetooth on app settings was off. Turned on and connected last night will try it out later. Thanks! Now just the Mode settings in the app not sure if that is set up for dual motors? Or single motors? Do you input motors as one motor or combine the two motors to one input number on the app? Anyways! :+1:

I have the bound motor direct drive with Xmatic app but the mph is reading 30mph after checking on a gps I’m only actually going 20mph I have the motor and wheel pulpy set to 1 any body had this before

You have pulley tooth count set to 1? If that’s what you’re saying you should change it to the number of teeth on each. Also set the wheel size correctly. Alternatively I believe in the data section of the app you can set it to use gps for speed :man_shrugging:

I’ll try changing it and having a play with it when the weather drys it’s super wet weather at the min. I thought because it was direct drive motors I had to leave the pulleys as 1 but I’ll try and change it to see if it’s more accurate

1 Like

Disregard what I said. I didn’t realize it was direct drive I’m not sure what the correct settings are for that. My bad sorry I should’ve read better :slight_smile:

No worries glad for any help I’ll just stick with the gps data for now hopefully the English weather will pick up so I can get out the house ! :grinning:

1 Like

1T motor 1T wheel pulley works for a direct drive. ( or any 1:1 ratio. )

it’s likely another setting that’s wrong.

1 Like

Amazing, thanks for the help!