Abrupt control, possible remote issue?

So I was test riding my first build (10s4p, Bestech HCX-D223V1, 2x Vanda Vesc 4.21, Dual HUB Motor) and the control is anything else than smooth. Both motors are connected over CAN bus and I am using the firefly receiver and remote, both working without connection issues. My min value at the firefly remote is 355, center 515 and max 655.

In the vesc tool’s input setup I noticed that my pulselength min is 0.15, center 0.7 and max 0.95. Do you think the difference between center and max should be the same as center and min? When I only accelerate a tiny bit on the firefly remote (~10%) it goes quite fast to 100% motor speed. For that reason I adjusted the throttle curve to -30% for braking and acceleration:


It helps to have a smooth start but as I am riding it is still very difficult to control the speed, not smooth at all.

I have tried in the past to use the recent firmware 3.52 but I failed because I didn’t manage to let both motors spin for some unknown reason, here is the thread about this issue. So for now I am sticking with FW 3.40

What do you think is the problem? Thanks!

did you run the ‘setup input wizard’ found under “welcome and wizards”?

Yes that is what I did

so first thing I noticed is that I didn’t place the hall sensor on my firefly remote directly below the magnets. Now I get values from 0 to 1023. Anyways, the problem is not the remote, it is the receiver. Haven’t solved it yet.

Now that you’ve changed the magnet placement in the remote, you may need to re-pair it with the receiver and redo your input setup.

I did. I even inverted the magnets, same issue. The remote is sending values between 0 and 1023 to the receiver which is good. It is a receiver issue I guess.