Acceptable DIY 6S3P BMS and battery setup?

Hey guys, so I am planning to make a 6S3P battery and BMS pack but was wondering if any battery wiz out there could verify the setup with me so that I don’t blow myself up trying to make the pack, or much less ruin expensive electronic equipment. I have attached the diagram in this post. Any help would be very much appreciated!


I’m assuming this is the BMS schema:

Your drawing is perfect. B- connects to the BMS via mains and the other wires via balance wires. Make sure you get a 6-pin JST-XH connector (those are meant for 5S) and not one made for 6S batteries.

Seem Legit :sunglasses: But don’t forget to put a fuses before your switch, so in case of a problem you won’t burn your esc.

@rubz yeah I basically followed that diagram but just added the cells in parallel

@JohnnyMeduse thanks for the heads up. Do you know if it matters where I put the fuse? as in which polarity to put the in-line fuse on?

Also, does it matter what polarity I put the 2-12S toggle switch on? I’ve heard that it is best to put it on the positive side of the circuit but there hasn’t been any proof why that is.

I think this is better on your positive side, because the battery is directly connect to all your electronics, on the negative side de BMS should act as a buffer for the current (good BMS are suppose to protect your circuit). And for the switch it really depend on the BMS you use.

so I’ve finished making the battery pack and wired the 2-14S toggle switch from Dexter, as shown in the picture. But now I run into a bit of a problem when trying to connect the voltmeter. When the voltmeter is wired (pos to pos; neg. to neg.), the reading shows a constant 100% no matter the battery state…even when it is drawing amps out of the pack. Does anyone know what I am doing wrong? Does it need be wired directly to the BMS instead of from the toggle switch?

thanks in advance

You would wire it between the switch and the ESC.

hm I tried that but the reading just stayed at a constant 100%. I measured the pack’s voltage and its at 21.8 which is nowhere near its capacity for 6S if I’m not mistaken

That is near 6S. Did you have the power switch on when it was %100?

Can you show me a picture of the voltage meter itself?

I bet the voltmeter is configured on the wrong S count

pressing that little button on the back of the voltmeter also did nothing…soo not sure what the problem is here

Have you ever configured the voltmeter? You should be able to scroll through the S count with the button. Check the instructions that came with it, or try holding or double tapping the button. It might be on a default 3s setting or something.

it never came with any instructions…bought it somewhat cheap from ebay lol. but yea I tried pressing the buttons a couple times but I haven’t tried holding or double tapping it so i’ll give that a try.

press it and hold, then turn on the meter. press the button again to switch types

it worked! Thanks so much @link5505!!!

1 Like