Bad Detection Received VESC


2 phases hit each other shortly when the motor did like a half spin :confused: but it seem like everything looks good , how to see what is defekt or what is working

i can’t get my vesc to detect my motor, It worked at the start and now it won’t work anymore :confused: can u guys tell whats is worng

It says under terminal when typing fault = FAULT_CODE_NONE vesc blinks red when pressing the arrow keys and when start motor detection,= Bad Detection Received ‚Äúin the corner where there stands connected‚ÄĚ and Detection failed. in the main window

Battery 7S 29 V 7.8 Ah 202WH

Enertion singel motor biggest

(Have tryed to update firmware did not help)

Change your max input voltage back to 57v. There’s no need to change it from default. Also your cut off is triggering that’s why your detection is failing. Your starting battery cut off at 4.1v per cell (29/7). You should really have it at about 3.3v per cell if you’re running li-ion 18650s, or 3.5-3.6~ for lipos.

Reset your detection parameters to default as well (6A current, 600 min erpm, .05 low duty)

Lastly, round down the integrator limit to the lowest 5 and bemf coupling to the lowest 50


Like so? (many i still did something wrong , have also tried whint only default settings) yes its Panasonic 18650

Your cutoff end should always ben lower than cut off start. Cut off start is when your VESC starts powering down and cut off end is when your VESC completely shuts off. Change the cut off end to 21 or 22 volts.

Also change your detection parameters back to default.

1 Like

hmm nope :confused: (Default bldc didt not work either)

Did you write config before you started detection again? Every change you make you have to write config. Rebooting the VESC doesn’t hurt either.

Yes yes :confused:

Can you try changing detection parameters back to default? You still have them on 14A current 690 min erpm and .13 low duty

This menu is default settings now

This is what I’m asking you to change

Like so?

Yep, so it seems settings are now correct. They definitely would not work the way it was before. Now, make sure your phase wires aren’t shorting on each other and that the rotor can on the motor spins pretty freely. If there’s heavy resistance on the can, then the phase wires are shorting out. Make sure none of the phase wires metal parts are touching.

Still not working out for me :confused: they aint touching :slight_smile:

Maby its the motor ? … I am confused what is broken or not :confused: (How to check that)

does the can spin freely?

Yes ,

Whit only to phases going to the motor it did wiggle and now its the same again

its saying same error when motor not plugged in :confused:

try switching the 3 phase wires around and redetecting.

tried that did not help only once there was a wiggle