BLDC Bad detection, FOC no problem. Spins no problem

Using ackmaniacs updated esc tool with his firmware (also tried with default 4.10 that comes with it).

Can move the motor very smooth with arrow keys but when I detect it in bldc, it spins up nicely and normally and slows down, then starts to jitter.

FocBox single drive

190Kv TB 6355 sensored TB 12s2p li ion 36V start cut off 33V end cut off

Motor max 60A Motor min -55A

Bat max 35A Bat min (regen) -15A

No load is on the motor and phase wires are properly isolated. For obvious reasons, I want to stick with bldc on 12s

*I know I’m going to get people telling me to use the search bar, but after almost 2hrs of reading I still got nothing.

CONCLUSION: For those who have the same problem; it’s just the vesc tool being buggy. Downgrade to 2.54 or similar and use the old BLDC tool

1 Like

use the search bar. lol kidding.

no faults? tried loosening motor from motor mount? nothing shorted (not just phase wires)?

actually, try unplugging the sensor. see if that works, if it does, take pics of the sensor wire and the order on the focbox

oh yea, and of course, is the sensor plugged into the correct port?

I have this same exact issue, using VESC Tool. No idea why. I have been using sensored FOC on 12S because I couldn’t figure out why the BLDC motor detection didn’t work.

Only had a problem when moving to FOCBOX’s, with my TB vescs, bldc sensored worked fine.

The only annoying thing about FOC is the stupid hard braking at slow speeds <1mph


can I get a pic of where the sensor wire is plugged in?

also, when did you buy the focboxes?

Cyber Monday, they came in today. Will get pictures when I’m back home

1 Like

They were part of the black Friday batch, I received them in December.

It would be very hard to plug the sensor wire into the incorrect port imo. Also the sensored FOC works great, and all hall sensors are detected.

1 Like

Just scared to shit running foc on 12s. I’ve been through the drv trauma


yea kinda forgot this was the focbox :wink:

super easy to confuse the ports on the TB vesc

1 Like

so lemme get this straight, all sensors and everything detect in FOC, just not BLDC? @ShutterShock


Precisely. I feel like this is a software problem

1 Like

the reason i will never stop using 2.18 or 2.54.

How do I downgrade to 2.54? Can’t find the firmware

The sensor detection fails when the motor spins in the wrong direction. At least that’s what happened to me, in BLDC only, FOC was working fine. I just had to swtich 2 phase wires and it went fine.

1 Like

Tried that too

This needs to be a negative number.

I’ve had this exact issue. Since upgrading the firmware on my FOCBOXs with the ackmaniac tool - they both detected in BLDC in the VESC tool but then one of the 2 wouldn’t in the new tool. I never managed to find out why unfortuntely however I’ve been running them in FOC (unsensored 168kv SK3s) on 12s for a few months now and had no issues at all. Much smoother start up too.

1 Like

Yes it is a negative, just made a typo here

Typos can destroy expensive hardware; please be careful!

1 Like

Typo on the post, not the vesc tool lol. I triple check everything there

yep exactly, I have no idea why. It won’t even get through the motor detection in BLDC, it fails every time.

1 Like