Bldc Tool isn't Recognizing my Vesc HELP

Hey guys, when I plug my vesc into my computer via the usb port after hooking it up to a power supply, a motor and a receiver, the bldc tool doesn’t recognize it - as in nothing pops up under the ‘serial connection’ tab after clicking the refresh arrow.

I’ve tried Uninstalling and re-installing the bldc tool, using different usb cables, using my lipos instead of a laptop power supply and plugging it into a different usb port on my computer but none of this has resolved the issue so far.

The vesc has 4.12 written on it, I got it from enertion and the bldc tool is windows version and says it supports firmwares 2.17 and 2.18.

When I hook the vesc up to batteries, a blue light comes on followed by three flashes of red.

I’ve gone through all of the vesc setup and connection videos, however in all of them the vesc is recognized straight away so I’m pretty sure they can’t help resolve this issue.

I’m not sure if this information is enough but I hope someone can help me out because I’m dying to get this thing going!!

Thanks heaps.

com port driver installed??

change the com port to another one and try again. mine is usually com1 or com4. you can check your device manager to get the correct port number.

ya, check from device manager there. at first, my computer cant recognize my vesc port also. i update the driver then works~~

Thanks @lowGuido @benwong!! after clicking update it tells me that “windows could not find driver software for your device” and that I should check the support section for driver software for my device.

Are any of these what I’m looking for?

i forget what is the driver name ady. you need refer to your missing driver name and update manually if auto update not working.

I have to same problem when I plug other things into the USB port they are recognized but not the 2 vesc’s

I have tried two different vesc’s powered by two different sources with 3 different cables

The bldc tool is blank in the com port section no options for any ports

I found that using a different computer worked for me.