Blow C9 Cap on VESC 4.12

Hello guys, I disassembled my board today, cleaned the electronics, made motor detection and when I went to ride it one one motor spinned even though it worked perfect on the bench.

I disassemble everything back again and one VESC did not turn on.

C9 seems to be fried.

On a brightside I had a new VESC here laying around and installed it on the board, everything went smoothly but when I did motor detection, I heard a click, VESC disconnected and the led is not turning on at all, damn!

Would it be possible that I’m getting a short on the motor?, the phase wires are perfectly isolated.

How can I know if the motor is not shorted?

If you can spin your motor by hand with no heavy resistance, the phase wires shouldn’t be shorting. I’d run it on the bench more, maybe grab the wheel to simulate some load.

As soon as I clicked on “detect” the brand new VESC blew!

It didn’t even tried to spin at all

Are you sure your not just having a bad nightmare right now. Try pinching yourself.

Sounds like a cursed motor. Did you find any resistance when spinning by hand?

Sounds like a short inside the motor open the motor and have a good look inside

1 Like

Damn! I wish this is only a nightmare, pinching myself only left me a bruise.

I’m able to freely spin the motors by hand, no resistance whatsoever, I even was able to update the VESC firmware and set the motor maximum values as always, but as soon as I pressed detect, a clak sounded inside the VESC followed by a disconnection from BLDC tool and no led at all.

What would be the best way to repair both VESCs, how do I know what are the specs of the C9 in order yo buy it locally?

There are no signs of blown C9 on the new VESC

According to the VESC 4.12 BOM, the C9 seems to be a 10uF 50v capacitor.

Hope some electronic expert could give me a hand here in order to confirm this?

There should be a BOM list where all the parts are listed and the manufacture number for them too. C9 =10uF 50V MOUSER 963-UMK316BBJ106ML-T

1 Like