BMS not charging battery? (Solved)

I’ve just setup my 12s bms on my eboard, and so far, it was working. I could turn the whole board on with the bms with an E-switch and have the board move on its own, but when I plugged it in to charge, it was not charging… My Charger showed a green light, but the pack was not fully charged. I’ve followed this diagram, just with two lipos instead of lion batteries.

Any help is greatly appreciated! Also, I can provide photos of my setup if that helps. EDIT: Accidentally wired negative wire that goes to the charge port to ground :roll_eyes:

I connected the charge port negative to C- on the BMS and tapped into the main positive wire for the positive wire of the charge port. I’ve measured all the balance leads and each cell is around 3.73-3.75. The board runs perfectly, just wont charge. This issue has really stumped me…

Here is how I wired the charge port. Black to C- and red to main positive wire. Here are how the balance ports are wired. I am quite sure however, that the batteries or balance wires are not to blame because I can read each voltage of the cell and no cells have a large voltage difference. (.02V at most)

Any insight about my issue would be greatly appreciated! :slight_smile:

I’ve just measured the charger plug and I’m reading the proper voltage (50.4V) and when measuring the charger port that’s connected to the bms, I get about 45V, which is the total voltage of my current pack.

You said you had this issue solved. May I ask what you did to fix it?

I know this not reply to your post but, I need to know if someone can tell me if I have for example 2 3s lipo batteries of 5500 each and 11.1v so 22.2v in total. Will a 24v esc work with it and a lower Amp and voltage bms can charge it like a 24v 18 amps.

bms:|153176838256|453032095835&pName=Balanced-BMS-8S-24V-18A-25A-35A-45A-60A-lipo-battery esc:


There are 3 terminals on my charge port. Negative, Ground, and positive. I accidentally wired my negative wire to ground.