Brake comes on hard completely randomly

So I finished my 1st build about a week ago and have spent the time fine tuning it and getting used to riding. I’ve had one big issue the whole time which I cant seem to figure out.

At what seems to be completely random times whilst riding the brake will just engage on full power stopping the board dead. Its been at relatively low speeds and I thought It had gone but today It happened again and I went flying. Not ideal. I’m fine but its a bit disconcerting and I want to get it fixed before I take it out again.

Its happened maybe 4 or 5 times. Does anyone know what might be causing something like this? I think it could be a loose connection but they all seem good so I’m a bit stumped.

Its a single motor 8s VESC setup.

@yakerman pls post screenshots of your BLDC Tool settings (and maybe photos of your build). I’m guessing that you need to check the voltage cutoff limits. It sounds you’re triggering a reboot because of voltage sag while you accelerate.

It could also be an adjustment you need to make to your PPM settings… maybe the trigger is not calibrated and it is randomly engaging the brakes.

What remote do you use? Maybe you are losing connection sometimes and the vesc engages the failsafe function

First of all you have the max current ramp step bug. So you should upgrade your firmware. Secondly please connect the vesc to your PC and have a look at the ppm tab. As in your Screenshots I can see that the ppm signal is good. But what happens when you switch off your remote. Does it stay at 1.55 pulse width or does it go much lower. If that is the case then you have remote connection dropouts and then the vesc thinks you brake. Because when the receiver doesn’t find the remote it goes back to the default pulse width.

Okay, I just turned off the remote whist connected and it stayed at 1.55. I’m using the mini remote btw. I’ll upgrade the firmware too.

I have the exact same problem, any news? Did updating the firmware change anything, or did you change something else? Thank you very much in advance

1 Like

I do seem to have fixed it but I made a few changes and I’m not sure exactly what the cause was or which change was the solution but this is what I did. I think it Treenutters theory about voltage sag was the most likely.

  • Updated to Ackmaniac’s firmware (which is awesome)
  • Switched to FOC (just because I fancied it, I’m not sure this will help)
  • Changed the Batt Max to 40. I think this is what stopped the problem but I did notice a reduction in power. I have since changed up back up to 50 and its been fine.
  • Increased the Motor max to 70 because I read this would help with startup torque. I noticed a slight increase.

Let me know how you get on I’m interested to know what you do to solve this.

Oh yeah I’m also running in Watt mode now

Ok cool I’ll try all of this and will keep you updated! I read about Ackmaniac’s Watt Mode, but didn’t dare to upgrade my Vesc firmware because of all the warnings. Worth the shot in your opinion?

I would definitely recommend Ackmaniac’s firmware and Watt mode. Super easy to upgrade to. As for FOC I didn’t have any issues myself but obviously lots of people have. It is good though!

One other thing I would check are your motor phase wires. I think if there is a loose connection with those then it will cause a similar problem.

I’m having a very similar issue. My board will randomly slam the brakes on while I’m riding it. I’m running a 6s (2x 3s 5000mah 40c batteries in series) setup, with dual 270kv motors and dual VESCs. Any chance anyone could help me out?

Since it appears that both motors slam on the brakes, I’ve narrowed it down to either the parameters for the remote not being set up correctly, the remote itself, or the VESCs not getting enough voltage so they reboot

Yeah so it turns out one of the motors had a bad solder connection and was locking up randomly… the system figured out one motor wasn’t spinning and siezed up I think. I just hope getting a replacement motor fixes the problem. Will keep you guys posted

Sorry for the late reply! In my case, it was very obvious, I super stupidly connected the 4mm motor wires to the 5.5mm from the VESC (good intuition, @yakerman) . Soldered the bigger connectors and it has been running without a hiccup since then! Will try installing WATT mode in the next few days :slight_smile: