Brakes way too sensitive

I checked everything on my esk8. Battery: 36v 4p 10s tested, can handle 45a continuous Motor: ESC: link no longer available but it is a vesc firmware 2.16 version 4.12 Controller:

My esk8 braking is way too sensitive and i was wondering how to change brake sensitivity. I am using current no reverse with brake and the displayed pulsewidth shows my throttle moving responsively and accurately to my inputs so my controller is good. Settings: IDK how to screen shot but let me know if u need more info motor max: 40A motor min (regen) -30A Battery max 40A Battery min (regen) -30A MAX Erpm at full brake: 100,000 MAX Erpm at full brake in current control mode: 100,000 Min Erpm: -100,000 Max Erpm: 100,000

The is actually a little bit funny and easy to fix. You max Erpm at full brake in current control mode is way too high. It stands for below this Erpm the VESC should do a full brake. Just check which value it is when you read the default settings and use that.

i changed it to 500Erpm for the full brake in both full brake and current control and now it works if it is going under 500rpm but anymore than that it just doesnt work. is there a value i might have changed unknowingly? i made the limits and ppm under app config. PID Max Erpm is 15000.00 deadband: .15 minimum pulsewidth: 1.12 maximum pulsewidth: 2.19 safestart is checked off

What do you mean by it doesn’t work? No brake at all or does it brake too soft? Maybe post Screenshots of you settings or start again with the default settings.

these are my personalized settings

i get no brakes at all after 500rpm i also tried resetting everything to default config and nothing changed

My ppm was the same as default but these r my default limits

try these parameter… and it should work just fine…

I would change this to -5A which will probably be too soft, then go up 5amps at a time until it feels good. I thinks somewhere between -10 and -20 will be good.

Also just keep the max ERPM at full brake and max ERPM at full brake under CC mode as per defaults, these seems to work for everyone. 300 and 1500 respectively.

His problem was the maximum input voltage of 42V. With a fully charged 10S battery it shut down each time the regenerative braking raised the voltage.