Broken focbox no lights

Hey i have 2 focboxes with problems… A few months ago i used them and only one would detect on BLDC tool the other one wouldnt. Both of them worked in rest i could connect the motor and remote and spin the motor but one of them would not detect on pc.

Today i tried to connect them again and none of them would even turn on … no lights would turn when connect them to the battery.

Who could give me a few idea of what can i try and do to understand what is wrong with them ??

Thank you.

Anyone in uk that repairs focboxes ??

1 Like

@carl.1 might be able to help or @Martinsp does repairs I think?

1 Like

Have you opened them up at all to see any obvious signs?.. -DRV chip -Fets + thermal pads … no clear film -Voltage regulator (Logic)

Do you have pictures of how they are connected?

Yeah i opened them couldnt see anything weird :-?? nothing burnt no idea. I will take some pictures when i can.

@ARetardedPillow How they are connected ?? i just connected the battery to the vesc ?? what do you mean?

1 Like

Like pictures of the solder joint and stuff, just making sure that the solder joint is nice and sturdy and they’re not connected in reverse polarity. Also check the joints of the phase wires and etc.

Pictures may be useful. As for solder joints, check if there is voltage on the last connector on focbox, if there is and the focbox does not show any signs of life, measure voltage on the ppm connector between red and black. There will most probably be 0V which would point to internal hardware failure. Would you be able to send us a picture of the PCB? Ideally of both focboxes and both sides maybe there are some signs of what happened

I do repair vescs, I am located in Slovakia. More info can be found here or pm if you have any questions.

Thank you @bigben for the mention.


1 Like

Thank you. Can you please check the CAN chip on the firs picture (small, 8 legs next to PPM wires) that the two black dots are not burn marks? They seem like burn marks, that would most probably be shorting the 5V line on your FOCBOX preventing it from turning on.

If the dots are burn marks, I would assume that the VESCs were connecting using CAN and the fault would be most probably same on both VESCs

There dont seem to be any obvious burn marks on the other pictures

The PPM is 5V hmm

on the focbox with the dots/burn marks? So you are also getting the blue LED?

yeah the one with burn marks im getting 5v on ppm but no led. No blue or red led are turning on when connected :-?? …

Ah sorry is not 5v on ppm… is fluctuating between 2 an 5… my bad x.x

Hmm that would be a short somewhere, there may be a problem with the DRV that is supposed to create the 5V and it is causing the fluctuation or there is something shorting it in a way.

If you want to try to repair them yourself, I would start with the CAN chip, it is the easiest to desolder and if the VESCs were connected via CAN it is pretty likely the problem. Not 100% but it is possible.

I understand. Yeah i had someone playing with it over CAN too… so is likely. Can you tell me what the chip is called or where could i find it.

Also any idea what could be the cause of it not being recognized by the pc ? I wasnt able to read it on BLDC tool so i couldnt program it.

Well if the VESC is not turning on the PC does not see anything connected. The PC only recognizes the VESC after it boots (after the initial red LED flashes)

The chip can be found here based in UK

1 Like

Yeah ofc i mean before the CAN got burnt. When it was working and i managed to spin the motors etc i still could not connect it to my laptop.

1 Like


Have you contacted Enertion Support? I think we can handle this for you. Please email at [email protected] Also let us know from where you purchased them.

1 Like

Hey @CarlCollins I got them from someone on forum and dont have waranty + had really bad experience with enertion support + late shipping and not in AU so idk feels a bit too complicated…

Thank you.

1 Like