BT05 a wolf in HM-10 clothing?

Hi bluetooth aficionados!

So I just excitedly connected my FOCBOX to my bluetooth module for the very first time using this schematic:



I got a flashing red light and all looks groovy. However my iphone can’t discover it BUT my laptop can. When my laptop detects it and I connect it shows it as ‘BT05’.

These are the modules I bought:

I’ve done a bit of research and there seems to be clones of the HM-10 called BT05 (amoung others) but they’re apparently essentially the same thing.

I’ve triple checked my connections but just cannot get my iphone (or any iphone in the house) to see it.

Have I been duped? The description says it connects to ios and the module looks identical to the others that people recommend on the forum but the BT05 has throw me and I’m wondering if these are the wrong thing or am I just being a dumbass?

I’ll take my board in to work tomorrow and see if one of the cool kids with an andriod can detect it but in the meantime would anyone have any suggestions? I’ve not come across this on the forum yet and I wondered if anyone else has encountered a similar thing?

Thanks in advance! :robot:


Are you trying to connect with bluetooth directly? Don’t have much ios experience. but you should try to connect with the vesc app. not ios bluetooth…


Hi @Skitzor - thanks for the fast reply!

Yeah I was trying with the bluetooth discovery in settings. I’ve downloaded @emmaanuel’s app (eSkate VESC) as I thought this was the only iphone version - plus it looks pretty badass! I can’t find a way to connect directly through the app tho…

1 Like

Thanks bud - but I get nothing but fresh air in my list:

ahh wait lemme take a look.

i would guess that your phone has a different transciever than your laptop, IOS is SUPER picky about bluetooth. when i connect mine, i just plug it in, turn on bluetooth, and go into the app and it’s sitting waiting for me.

you can find legit hm-10’s on aliexpress for about $2.50, I can link you if you want

oh yea, on the back of the module, does it say 3.3-6v?

1 Like

Thanks for the help. Yeah I’ve got the feeling that it just doesn’t like them. Yep - 3.3-6v. They’re the ones from the link above :slight_smile:

1 Like

I use these ones for my modules: use them daily on IOS and have 18 of them out in the wild :slight_smile:

1 Like

Thanks for the link. Yeah I was being lazy and bought local to save on delivery time. The description is identical to the one you sent though and they look the same. Clearly they’re not though!! :smile: Or I’m missing something obvious…

Take a picture of the module you have in hand.

HM-10 has 1 IC on the module, HC-05 has 2 ICs on the module.

Also HC-05 if I remember correctly is Bluetooth classic/EDR

1 Like

@DanSkates Have you tried changing the baud rate (to 96000) in whichever vesc-tool/bldc-tool you are using to set up your vescs?

1 Like

It’s the exact module in the link - identical to that. I’ll share a pic when I get home tonight though just to be sure.

Just checked on an Android phone and it also picks up the module as a BT05.

Think I’ll just buy a new module and see if that works. This might be an intersting thread for others though if it is a case of mistaken identity so others don’t make the same mistake. Fairly inexpensive mistake to make but just annoying on postage times :thinking:

Try the app nRF Connect. It’s a much more powerful tool for finding and diagnosing bluetooth issues on iOS. Might help you out. It’s free, so worth a shot

1 Like

Wow…that’s awesome! Well…it found it a found it at least:

But I’ve no idea what to do with it :sweat_smile: It confirms my suspicions tho.

Tried to load it into the eSkate VESC app with it connected (via the nRF Connect app) but it still doesn’t see it so I’m guessing it’s not compatible - also I can’t pick it up in the AcKmaniac BLDC tool. Tripled checked all my connections and ensured baud is 9600…hmmmmmm might quickly research if the baud should be different for a BT05 module? If that fails they’re going in the bin! :joy:

"BT05-A mini BLE Bluetooth V4.0 iBeacon

Similar modules sold as DX-BT05. This module is based on the Bolutek CC41-A. This is the same form factor as the HM-11, however, the layout is different. The BT05 is sometimes sold as a HM-10 and regarded as a copy of the HM-10, however, I don’t see these as copies more like a different version of the same thing. Not sure where these originate from as I can’t find this version on the bolutek website nor can I find a manufacturer (didn’t spend too long looking though)."

Grrrrr…looks the same though - baud rate is the same. Anyone else used this with success?? Am I flogging a dead horse here? :horse:

Looks like it’s possible to flash it with HM-10 firmware…could be worth investigating and quicker than shipping a new one if it works! Nothing to loose so I’ll let you know if I manage it…


I’ll check what the Bluetooth services on my HM-10 modules are when I get home, so we can do a comparison.

You can then decide if you want to proceed with the firmware re-flash

1 Like

The BT05-module has a different form factor than the HM-10.

If you ordered the modules that you linked to the Ebay page, then most likely they are the AT-09 -module.

Based on the info in the , it would actually seem that the “HM-10”-modules that I ordered and received are actually AT-09 -modules. Based on the simple fact that there is a pushbutton footprint next to the header, where as the real HM-10 module doesn’t.

But at least when I tested them, they worked as a serial-bridge, so it still fulfills it’s purpose.

Also consider the possibility that the bluetooth device name could simply have been changed with AT-commands at some point in it’s production/use (AT-commands in link)

Strange, you should see the device when you click on “Select a VESC device”. Did you click on this button ? Another thing: Make sure your device is not already connected to your iPhone in the iOS bluetooth section.

This same thing has happened to me. My samsung S9 cannot register it, but it appears on my wife’s phone as BT05. I actually purchased the same one that is listed on aliexpress from a link someone posted here, claiming it is real.