Can bus / BLDC issue

A month ago I shorted the canbus receiver on my 4.10 vesc. Since then I have replaced the chip. Now when I try to connect dual vesc´s via canbus I get the fail message “No firmware read response” and the vesc disconnects. This happens as soon as I check the Can FWD box.

What I have tried :

  • Both vesc as master and slave
  • Installed st link drivers
  • Different usb cable
  • Different CANBUS cable

I´m not sure what to try next. Would appreciate some help here.


What are you using CAN FWD for? You can run VESC’s via can without forwarding. I was told that you should use that unless there is something specific to use it for and that it was very risky.

To check if they are communicating. The master vesc´s motor is only rotating

On the master: under ppm, check the box for enable multiple vesc’s over canbus, and on the slave: on the app tab, check the box for send status over canbus. Make sure the id in the app tab is different for each vesc. for simplicity and this example, set master to 0 and slave to 1. Now, plug into master, click connect, before you check the box for connecting over canbus, make sure the number is on 1, and check the box. It should connect then.

1 Like

Yup tried it again as you explained. Still no go :confused:

If it still doesn’t work you could ditch the canbus cable. Get a Y ppm splitter and run both Vescs as masters. Only feed 5v from one Vesc to the receiver though. You have to clip the red wire on one leg of the splitter.

1 Like

Yeah I have been running split servo for couple of months now. But I would like to try out @Ackmaniac ´s monitor app. And therfor I need canbus to work so I can get data from both vesc´s right?

Still learning.

thanks for your help

If you have a multimeter, another way to check is to turn off your vescs, and check the pins on the back of vesc’s canbus port. The middle two should be connected one and one, but not to each other. You should not get a cross signal, just pin 2 to pin 2 and pin 3 to pin 3 should be connected. If that shows them connected, could be a malfunction in one of the vescs.



1 Like

I run a BT module with monitoring app. I just monitor one Vesc and assume that the other is the same or close enough.

I will try that now… need to remove some glue first. Should the multimeter be in “diode” mode?

hehe It´s bothering me too much for letting it be. need to fix it :smiley:

I’m not sure what the modes called, but if you ouch the 2 leads together, it’ll beep until you break the circuit. Only 1 mode that does it, so you’ll find it, haha

1 Like

This is the cheap meter I got. Updating how it goes

I can relate to that.

1 Like

Didn´t find a beeping mode on my m.m But when reading 200 ohm it measure ~ 42.0 on both can low and high.

Still no solution. Is there a way to check individuell vesc for can bus communication?

doesn’t the diode test beep?

My multineter doesn’t beep to my knowledge

Diod test is reading 075 on both pinns

Hi @L3chef sorry to hijack your thread - I’m just in the process of figuring out how to replace the canbus chip on my FOCBOX as per this topic here

Any advice you can give towards finding the correct chip and the method you used? Those things are bloody tiny!!