Can't connect 2 VESCs 6.7 over canbus

Yesterday I purchased 2 Makerbase MKSESC 6.7, tried to connect it , it worked , showed 2 VESC 1 master 1 Slave , then set up the motors and the remote rebooted and now it wont connect to the second VESC via canbus. It just doesn’t appear in the bottom left corner anymore only the master one, tried updating firmware a couple of times nothing, tried using different canbus cable didn’t work. Tried using different computers won’t help.

1 Like

I would just do a split ppm and make them both masters. You can avoid this issue so much just by doing that.

Just make one with all 3 wires and then split it and remove the 5v line for the second one. Its much better than doing it via canbus, since this can sometimes be the reason.

But, have you also updated the firmware on the second esc? This is also a case.

1 Like

What remote?

I’m using Flipsky VX1 using ppm

1 Like

If you plug a USB data/sync (not charge) cable into each device, does each device have the same firmware version and a different CANBUS id?