Charger not charging

Hello everyone :grin:

I recently finished my diy board and was really satisfied with it, unfortunately i ordered a 42v charger off of AliExpress and it didn’t reach me but that’s a story for another time so I am using my friend’s charger. Anyways I ordered a Bosch 42v 3.5a for electric bikes and soldered a new plug that I found laying around and was really happy about it. image image image So I plugged it in and left it for a whole day only to come back, turn the board on and find out that it didn’t charge a single bit. The problem too is that there isn’t any light on the charger to indicate that it is charging or no so at the beginning it was a guessing game but now I’m sure it doesn’t charge.

So what do you guys think I could do to make it work?

Can you measure the voltage of the charger to be sure it’s working?


Yea I just measured it its 42.06v

You sure you got the polarity right?

First few things to check at if the bms is receiving the 42v from charger, if yes then could be a bms issue or wiring issue between the bms and battery. If it’s not getting charge I would first check continuity between the plug and charger pcb, if that’s all good check to make sure the wiring between charge port and bms is all g. Also check to make sure that the plug you have is actually the same as your charge port. There are different sized inside prongs and you may be larger than the other and not making contact.

One of these is likely to be your issue so I’d go through these and thorough check your wiring and polarity, posting your wiring schematic here would also be beneficial.

Ps. do not stick the multimeter in the charger port no matter what lol

1 Like

plug it into a spare charge port not hooked up to a battery. try and measure voltage off the back of the port and make sure its correct. some have 3 pins and 1 isnt even hooked up

1 Like

I did that and also got a measurement of 42.06v

Yes I am sure I even tested it out before soldering the plug

I checked every single one of those point and got the results I was waiting for which is 42.06v, to the point that I disassembled my whole board and measured every single contact to make sure that the power was getting through and it got through in every single contact, it is the correct plug cuz I tested the plug with another charger and it charged my board fully.

What I wasn’t comfortable about was that the charger was making weird noise every 3-4 second while it is plugged in the board, it sounded like spark inside the power brick and that was annoying me a bit, tried opening the brick but unfortunately it’s sealed with three layers of silicon and two other (german quality :sweat_smile: )

Hmm this is weird then. May I ask what bms you are using? And if it would be possible to try and charge the battery a little directly from the charger. This will tell you if it’s a battery wiring issue or bms problem

If it charges fine directly to the battery I would assume a dodgy bms, if it doesn’t charge the battery then there could be a problem in the battery wiring.

Also something I just thought of is the bms must not be connecting the battery to the charger, because if it was you wouldn’t have measured 42v at the contacts but somthing lower similar to the batteries current voltage.

Also are you bypassing the bms for charge only or discharging through it

1 Like

This is the bms I am using: image

I just tried it and it kept on making the weird spark noise from inside the charger which I think indicates that it is not charging but let’s not also forget that with my friend’s 42v 2a ownboard charger it charges without a problem

Yea yea right I just remember when I measured the battery contacts I got 36v not 42 sorry :sweat_smile:

I am discharging through the bms

I had the same problem a while ago and it was that my wiring from my bms to my batteries was wrong. have you double checked your wiring?

I am pretty sure it is not from the bms cuz when I charge with other chargers it charges without a problem but with the one I have it doesn’t

You have solved the problem. Your charger is defective. Your gonna need a new charger.


Yea I guess so, I thought maybe there was a fault with the board or something but I guess I just have to get a new charger

Yeah it must be the charger then. I thought you said that the charger worked on your friends board Burbank I must have read it round the wrong way.

You should be able to get a replacement or refund, and get a new one