Could someone help me connect my remote to my VESC?

I was wondering if someone could help me trouble shoot my problem with connecting my remote to my VESC tool app (I’m using the mobile version) and subsequently my VESC. I’m creating my first electric skateboard and I’m using the

VX2 Pro remote from M Boards, A FSESC 4 50A Based on VESC4 from M Boards (but it is no longer listed on the website), and a FSESC 4.12 50A Based on VESC4.12 from FLIPSKY.

For the connecters:

I have a Bluetooth Module 2.4G Wireless Based upon the nrf51_vesc project to connect the VESCs to my phone, the Bluetooth module that came with the VX2 Pro remote, and a CAN connector to link up the VESCs.

For some reason my VX2 Pro remote refuses to connect to the VESC tool app. I have checked the pinning on the connectors, and they seem to be correct. I have switched the APP CFG section to UART and tried PPM and UART. I don’t understand what any of that means, but with some troubleshooting resources it said that it might work. Whenever I try to do the Setup Input on the VESC tool app it never measures any of the inputs. Does anyone know any resources that might be helpful or any ways I can go about fixing it?

If you connect your receiver into your esc, and set up your controller to UART only, does it still show any signs the receiver is on?

And did you check that your rx/tx wires are on properly? Sometimes the rx/tx are switched wrongly so you may need to flip them around so instead of rx/tx, it can be rx/rx and vice-versa, especially on flipsky products.

thank you so much, I will check and see if it works. thank you so much

OK, heres the deal. DO not hook up reciever till after you FOC. Then, turn trans on. Then plug in reciever. But first, switch tab for pairing in vesc tool. This took me days to get working.

quick question what is FOC and trans?

motor setup

The controller gives feedback, even tell the battery charge. I checked the rx/tx connection and they seem to be correct. it just wont register inputs in the VESC tool.

thank you so much for the help.

Oh you wont see inputs if you’re using uart. You just set it up as uart and just work it out as you would ppm.

Unless they fixed it to where you can see it.