Dead wiiceiver from Austin David. HELP! (Fixed Kind Of)

I have about 30 miles on my board and my wiiceover will no longer turn on. I changed nothing and don’t know what it wrong! I know it is the wiiceiver because I can connect the esc programming card with no problems and when I change a setting the motor beeps… Can anyone help?! Thanks!!!

What are the 2 leds doing? Are they on? Are they flashing?

No, the leds are not on, neither is the red light on the actual receiver for the wii remote. @claudiofiore88 Thanks for the help!

why dont you swap out the remote for a wired one to see if its the receiver or the remote and the block

There is no power to the board but I will give it a try, thanks

I ran into a different problem than this one when I received my first wiiceiever from @torqueboards. Mine was powering on, but it didn’t accept the input from the nunchuck. I just ended getting a replacement. If you just bought it, it’s probably still under warranty assuming you didn’t fry it from water damage or something.

Might try looking into another ATMega328. You can pull one out of an Arduino Uno after writing the Wiiceiver software to it. I wouldn’t advise getting another one off the internet as it won’t have a bootloader on it yet, unless you got the tools.

1 Like

That worked!!! :slight_smile: Thank you!! I stole the chip out of the arduino!!! Do you know why the problem occurred so it dosnt happen again?

Now the nunchuck will not connect? Not sure why… A wired nunchuck works just fine, any tips?

@JLabs - You’ll need to program the Atmega. You can check on Austin’s site and see how to load the bootloader onto the Atmega. You can flash with Arduino.

To be honest, I’m not sure. It could possibly be the wiring inside the Nunchucks receiver.

These exact issues happened to me as well, before switching to @torqueboards mini remote.

(EXCELLENT by the way)

Just so you know. Don’t ride it like that. make sure you crack open the dongle and solder it first or else you may street your face.

@JLabs, you will probably find there was a power spike to the micro-controller, due to something or other. Because if lights aren’t on, the chip is dead. It may have something to do with Austin’s peripheral circuit. I just used an Arduino Pro Mini for my wiiceiver. Was like $8, and I got my nunchuck for $15 and everything’s still holding strong as after about 3 months of use.

Re. what @torqueboards said, it seems like your software is fine, seeing as you say the wired remote is working.

What is happening in terms of the LEDs on the dongle and the nunchuck? Are they talking/synced? If they are, then the problem is likely to be the connections between the dongle and the wiiceiver circuit. If they’re not, then it’s likely you have a syncing issue.

Does your dongle/nunchuck have a sync button? What I usually do when my dongle and nunchuck aren’t talking is turn everything off, turn on the wiiceiver, wait a couple of seconds for the wiiceiver to boot up, turn on the nunchuck. If it’s not synced, I’ll then press the sync button on the nunchuck. If it’s still not synced, I’ll press the button on the dongle. And if still not, I’ll press the button on the nunchuck again. A combination of those things usually works for me. :blush:

I completely agree with @lowGuido, solder those dongle connections.

The leds are solid and wont connect, dongle light is on and the light is blinking on the nunchuck. I plugged it into a normal wii remote and it wont connect, any suggestions? @makepeace @lowGuido @lilracerboi @torqueboards @claudiofiore88 @barajabali

The Nunchuck receiver might be dead. This happened to me as well, completely out of nowhere, it just stopped working. Wiiceiver worked fine though, since a wired nunchuck worked with it, but I don’t know what caused the issue.

Yes, exactly… The light on the dongle is on tho… @lilracerboi

Oh whoops, nevermind. I read your comment wrong. When I was using the Wiiceiver it would do kind of the same thing. Both lights blinking, but not connecting. I would just remove the battery from the nunchuck and put it back in to reset it, then wait for the led to shut off. It would connect after that, but I don’t know if your situation is the same.

Dude lose the wiiceiver just get a :point_down:t2:

It’s just as small…it has a trigger for better throttle control … And easy to replace

Yes but there is Bo cruise control and throttle smoothing with the thy 120a 6s esc

Cruise control really ?

To each their own