Different torque on a dual build same setup (problem)

Hey guys, as the title says, I have a build running identical dual setup, I can feel by hand, that one motor has a lot less torque while starting up, I can barely hold one, while I can stop another by a slight force to a dead stop, I do run same vescs settings on both, I don’t feel any drifting of one side or the other, I had a pulley slipped on the stronger motor and had to ride a bit with a weaker one and was not impresive at all, what this problem could be?

1 Like

Have you double and triple checked both vesc settings? The only other thing I can thing of is weak solder joint somewhere on the weak side.

Hope you find the reason.

Did you try plugging the each motor into the opposite VESC? This will make it easier to determine if the problem is with the motor, VESC or maybe one of your solder or wiring connections.


Also pictures might be helpful. You would be amazed and what issues I have seen solved on this forum just by someone noticing something in a picture.

1 Like

Here it is, I have shortened the vesc wires today from the plug side and tested the board on a single motor each side, the stronger motor doesn’t move now! What could’ve I do wrong? Vesc seems fine, but can’t detect the motor no more.IMG_20180705_163914

bet a phase wire either shorted or broke in the motor. seems to happen a lot with the vibrations on a skateboard

1 Like

So I should open the motor up?

I agree with Hummie. What motors are you using?

I usually recommend just doing a return. If you bought certain hobbyking motors, I can tell you I always had problems with them shorting because of where the wires entered the motor was sharp. If you have those motors you are better off just trying to make a return and picking up ones from @torqueboards

You can’t usually return a motor that you have opened up.

if you open it and close it they wont know. maybe you can find where the problem is and maybe insulate it. a multimeter helps

Apearantly the motors are fine, both of them work from the same vesc, but the slave one is acting up, the green light is on then I push the throtle, but the motor is still not spining and vesc can’t detected it?

Edit I’m using torgue board parts with 6374 motors.

I’d try restoring the default settings on the slave or reading the settings from the master and then writing those settings to the slave but not before changing the slave id first. Afterwards if you can run motor detection on the slave, setup the slave accordingly again ie in your desired settings.

Don’t forget to always read and then write settings afterwards.

New problem started to hapen, on one of the last configuration settings, the motor on the slave starts spining at it’s max for now reason, and doesn’t stop besides turning the power off, so now i don’t know hot to set it?

I have had this too but unfortunately I don’t remember why it happened. I do know that I played with the settings on the slave to resolve it. Try going to app settings and return the settings to default.

So going back and forth this happened, the motor also was spinning while I was programing the slave vesc, motor started spinning and I saw a little spark and the board shut off, now I also can’t turn the other vesc on, my receiver light is blinking, but the LCD is off witch means the bms went to a safe cut off, it usually would go back on reconnecting the LCD but this time it is still off, so now I don’t know if it’s the bms, the LCD or both of my vescs went dead, @torqueboards could you chip in?IMG_20180710_185005

Edit, I have found, that both of mine vescs dvr chips blew out, how could’ve this happen? Is this my fault?

Check for shorts in the phase wire. Also, If the motors were spinning at full speed on bench, that might have caused the DRV to blow.