Disabling brakes when ADC is set to zero


I am facing an scenario where I am using a receiver/pot to control the speed of the motor. When the ADC is put to zero, the motor stops and the brakes are enabled. this is consuming some current. I am trying to disable the brakes so that the motor will be free to move as it is before powering the motor. I am also trying to do that to reduce the current consumption(for braking).

Is there a way I could disable in the app or the code? Can you point me in the place where in the code i can disable that? Thanks!

1 Like

I’m not a smart man but I know what love is. I think you can accomplish what you want in mapping. . .

1 Like

I tried that but did not help.

Take a pic of what your settings are now and post them all.

Here they are

Change control mode.

Which mode are you suggesting?

Oh sorry… current no reverse with brake

I configured that settings. I looked at the RT, the issue I am having is the lowest speed is 0 and as soon as I slightly increase the pot value, it ramps to maximum. I am unable to get the speed in between the min and max value in current no brake or any other option except duty cycle. But in duty cycle I am having the issue with the brakes.

Maybe @b264 could chime in his thoughts

I think you are doing this test with wheels unloaded? They need load on them

1 Like

I tried both loaded and unloaded, had the same effect. I tried changing the pot value from 2k to 10k based on recommendation from other forum and that did not help as well.