DIYEBOARD 10s5p Belt Drive Kit Motor Shorted...or Fried ESC?

Hi guys!

I’m new here so hopefully posting this in the right place. A couple of years ago during my spring break from college I ordered and assembled a DIYEBOARD 10s5p dual belt drive kit on a vanguard clone. It was my first build and was a dream come true for the first 9 months or so. Then one day I was riding up a rather steep hill (maybe 10-11% gradient), and the board totally stopped working. I jumped off, and here’s what I found…

The left motor has a ton of resistance, whether the power is on or off, and whether the throttle is on or off. But if I unplugged the connection between the motor and the ESC, that resistance went away and it started to spin freely again. The right motor is totally fine and behaves as normal.

I have tried unplugging and replugging all of the connections. No luck. I have tried unpairing and re-pairing the controller, per DIYEBOARD’s advice, also to no avail. Now, to make matters worse, I can’t even access the website (seems to have been taken down), and I’ve been reading that they were selling crap gear all along.

So how can I diagnose the issue? Is it just the motor I need to replace, or also the ESC? Where can I buy compatible parts now that the website is no longer up?

Thank you SO much in advance for taking the time to help me out. I really can’t wait to get back to riding! Please let me know if there’s any more info I can provide.

Best, Eli

1 Like

Site is up for me:

It sounds like you have an issue with your phase wires. Check and make sure all your bullets are securely attached to the phase wires.

Those ESCs are awful but last forever.

Thanks for the tip. Being a total newbie, I’m not sure how to check that the phase wires are connected to the bullets. How would I go about that?

1 Like

Hold the wire a few inches from the bullets and then try to tug the bullets off. Also twist them a bit.