Enertion Nano-X not charging // Mystery solved

So, I will post this since it might me helpful to others (with the same issue) in the future:

My nano X died after some days of use. I did not notice it right away because I only used it for 2 days 3 months ago and then picked it up again yesterday.

I suspected a faulty LiPo, so I swaped it with the one from an older Winning remote. Again no luck, it still didn’t charge and the voltage of the new battery kept lowering. After that I tried resoldering: still no luck…

It turned out that if the remote was off, it would not charge the battery. So it olny charges when it is ON.

Im quite sure this should not be this way, if yes let me know.

Result: Some hours wasted + One dead Lipo at 1,2V (Original one) …

Im not sure what enertion charges for this remote, but not even having a under voltage protection is too much.



1 Like

That is strang my remote charges when off…when plugged in and charging you should get red led.

no red LED Just the GREEN blinks trying to bind…


1 Like

Answered via DM already

1 Like

What was the issue?

I have 3 Nano-x’s. one works as expected - the red light lights up until it is fully charged. The second one the green light blinks during charging (and before pairing) and the red light never lights up.

The first one took forever to get here so probably shipped out of Australia and I think was the last batch before they started shipping them direct from China. The second one is likely the first batch directly shipped from China and I suspect that they shipped that batch with the wrong firmware.

The third was the same as the second, until tonight, when it stopped charging altogether and gets hot when I plug the USB cable in. I’m waiting for a response from Enertion but I suspect what has happened is the battery over-discharged and now won’t take a charge, thus the charge chip is getting hot.

Open the remote and check the battery phase leads with your multimeter (While the micro-USB charger is plugged). Observe if there is any difference with the power switch toggled ON and OFF.

Thanks @bevilacqua - I don’t want to crack it open just yet in case Enertion decides that invalidates the warranty.

Update, this seems to have cleared itself up without any intervention (which is to say I probably mis-diagnosed it).

It’s taking a charge and the 2 blinks have gone away.

Best guess is that it was catastrophically discharged and just needed a long time on the charger.

I’m having a similar issue, my nano x is blinking green when charging. Since it’s the first time I’m charging it I have no idea if it’s actually charging or just ready to bind. What do I do?

1 Like

Yeah I had 6 like this. @CarlCollins


So what did you do?

Contact me. Shoot me an email at [email protected]

@Sender They are able to hold the charge?

Mine would not hold charge. I still have 1 here at the house. Bara replaced 4 of the 5 I sent in.


@Sender great so bara took care of it :slight_smile:


Hey bara :slight_smile: I sent you one right now.

Hello! did you make a ticket with support?

If by that you mean sending an email at [email protected], which you asked me to, then yes :slight_smile:

1 Like