Enertion (Steez) remote not connecting to receiver

Hey guys, I’ve just finished putting my board back together after having my VESC repaired by @chaka and everything seems to be working fine except for my Enertion remote. I’ve updated my VESC settings in the BLDC tool and have selected PPM mode. When I turn the board on, the remote’s receiver keeps flashing a red LED as usual but when I turn the remote on, it doesn’t seem to connect. Usually the receiver will start flashing faster at this stage but this isn’t happening. I’ve tried @jgraham232’s steps on this page but nothing happens with the remote when I turn the skateboard on after I’ve pressed the B button 10 times.

Any ideas?

  1. Turn off the board
  2. Hold A on remote for 3 seconds to power on remote.
  3. Press Down the throttle stick C, it’s a button! The Left green light will flash
  4. Now, Press the B button 10 times - in under 10 Seconds. The lights on remote should now turn off.
  5. Power on the board
  6. The green light on the remote will flash 2 times. Pause, then 2 times pause. etc etc. its on channel 2
  7. Use the throttle stick & push up once to go to channel 3
  8. The green light on the remote will flash 3 times. Pause, then 3 times pause. etc. etc its on channel 3
  9. You have now selected Channel 3.
  10. Push up again to select Channel 4, up again for 5, etc etc.
  11. Once you are happy with channel number selection, press C
  12. Now press A to save & exit.
1 Like

Hey man, as I mentioned in my original post I’ve tried these steps but I can’t get any further than step 5 as nothing seems to happen with the remote when I turn the board on :confused:

How did you end up fixing it. I have the exact same issue!

Bought a GT2B :stuck_out_tongue: Highly recommended, haven’t had a single cut out.

the person who has my raptor is having the same issue. You can contact enertion and they can resolve it, alternatively you can just get a gt2b like the person above me said. If your’e not comfortable putting the receiver in the board and binding it, you can always commission LHB to do the labor for you.

I think my Steez/Maytech remote got too empty as well and the frequency list on the remote is wiped…