Enertion Vesc can't connect to my pc.(Only blue led on)

Hello, I have ordered Enertion 4.12 Vesc from the last batch. Now I’m trying to set up it, and run motor detection. Firstly, I connented vesc over the usb port and then powered it with 12V PSU. But only blue led is on. I have tried different usb cables even swopped pc’s, but the same problem occurs. Maybe you have suggestion?

Have you checked for errors with the drivers?

I had a similar situation, which was resolved by installing a driver I got from an arduino site. You can tell if that’s the problem by looking in the device manager.(What O.S. is your pc? The following is only relevant if you’re using windows) I can’t remember clearly, but i think it was “tiny” or something similar.

I’ll try and find the link tomorrow if someone else doesn’t beat me to it.

1 Like

I’m running windows 8

You might be missing firmware and/ or boot loader on the vesc. You have to get an STLINK v2 to flash the firmware

But all of the enertion vesc’s has a firmware and are tested before shipping. I’m right @onloop ???

There’s been instances were enertion vescs have shipped without them. You should try contacting their support. If anything it might easier to do it yourself, you can find them on eBay for less than 10 USD.

but then I need linux or ubuntu… It seems so confusing…

before going to the conclusion that the vesc doesn’t have any firmware…

can you post some picture of it and maybe a video of the booting sequence (to see what the led does when you power up the vesc)

exemple of video:

Also have you try to contact enertion support ?

  1. I connect vesc over the USB port. (the usb cable is capable to send data)
  2. I connected vesc with 12V psu
  3. Blue led appears and nothing else happens
  4. Open BLDC tool and there is only com1 port… Maybe I need some kind of drivers? Yes, I contacted support, but I guess they will say: “go to esk8 builders forum”

Please contact enertion support… if this is a firmware issue they will guide you through the process, you also don’t need linux

can I follow this video? https://www.youtube.com/watch?v=H4sbDhRcaOQ Can you post a link where I can buy proper STLINK v2?

The same problem:

Have you setup the com port correctly?

How to do that?

I had the same problem with MEB and DIY VESCs, turned out to be the battery pack.

1 Like

That video of the VESC won’t connect is mine. Enertion support asked for video evidence when I had the same problem as you. After them reviewing the video they agreed that there was no booted loader. I told them I didn’t have kwoledge or equipement to flash it myself and they agreed to compensate by replacing it with a VESC x. I’m still waiting for shipment 3 months on I believe.

1 Like

There is your first problem, lol

Sorry that I can’t be of any help.

Try installing the stm32 driver mentioned in


First check in the device manager though to make sure that the lack of driver is your problem, if so, you’ll see the usual black “!” on a yellow dot; For some reason it doesn’t seem to install correctly on windows 8.

1 Like

Hello, but I have already tried ir with windows 7, but the same problem occurs. I think the Vesc actually doesn’t have any bootloader/firmware… Yes, I tried this driver, but it doesn’t work as well.

I had to use three different usb cables until my computer saw the VESC and installed the drivers (virtual com port) on its own. There are mini usb cables out there that are only used for charging stuff. In the end I used one that came with an Arduino - that way I was sure that data transfer is indeed possible.

1 Like