Enertion VESC Failure - [closed]

I’ve been finalizing my build in this thread and today I attempted to spin up the motors and only one VESC appears to be working correctly. Connection with Nunchuck was OK. CANbus communication was OK.

VESC HW version: 4.10 from Enertion’s recent batch. FW version : 2.5 BLDC version : 2.5

When I spin up the motors, only the slave VESC spins up as it should, the other one doesn’t budge. I switched motor/VESC connection to verify motors are OK and I can conclude that the slave VESC and both motors are OK, there is a problem with the master VESC.

When I try to spin up the motor gently, it jitters: VIDEO

Realtime data:

When I try to spin up the motor abruptly, it jolts, I get red LED and the VESC loses connection with the BLDC tool: VIDEO

Realtime data:

I’ve reproduced this problem with two dfferent power supplies as well as my 12S pack. I’ve briefly seen a variety of errors in the realtime data window: DRV_8302, UNDER_VOLTAGE and ABS_OVER_CURRENT, but generally there is no fault reported.

When I try to run motor detection get an error code saying “bad detection data received” or something along those lines. Detection obviously fails.

I’ve tried reflashing the firmware and reloading the R-SPEC 6355 default XML file, which doesn’t change anything.

I’ve inspected the VESC under a loupe and cannot find any obvious bridging. Here are the high-res pictures if you want to pixel-peep:

I’m afraid I may have received a bad VESC from Enertion.

Can anyone come up with additional troubleshooting tips ?



Remove those metal nuts near the motor wires and use nylon spacers or nuts to fasten instead.


I measured those, they’re not connected to anything so thay can’t be causing the problem. I also had heat shrink on the nuts but took it off when I removed the VESC. But you’re right, a nylon nut would be better. On my todo list.

The symptoms you are having are indicative of a bridged gate pin on your mosfets. Be sure this nut is not bridging this area here.

It also looks like you may have a solder bridge on the stm chip but it is hard to tell from here.


Check this area too. It looks like a bad short just waiting to happen.

1 Like

I removed all nuts and rechecked the mosfets for bridging, nothing.

Which is the STM chip ?

I inspected the power leads coming onto the PCB and was appalled by what I saw… Strands of copper just waiting to touch something.

But for tthe time being, these don’t seem to be touching anything, so they cannot be the source of the problem.

1 Like

These two spots look suspect But it is hard to tell from a photo. It could be something else.

I agree that those wires are probably not causing anything at the moment but it is just a matter of time. If you are good with an iron I would suggest replacing all the cheap car audio cable with high strand-count silicon cable if you can get that VESC working.

I will echo @chaka’s advice. The wire that comes on the enertion VESC is very cheap and can break while riding which can be very dangerous (happened to me).

Switch it out with high strand count cables ASAP.

@chaka there are absolutely no bridges on the processor. Besides, wouldn’t bridges on the processor make flashing new firmware a problem ?

Anyway, I don’t think I’m going to modify anything further on this VESC, it’s clearly a dud. I’m contacting Enertion and claiming warranty. We’ll see how that goes.

Those cables are unacceptable. That should of been resolved before shipping but obviously got missed. I appologise for that. Next time I won’t rush to ship to ensure everything is checked.

Please submit an RA via our website.

RA submitted, waiting for authorization to return + return address.

Just to close this thread, I received a store-credit refund from Enertion for this defective VESC. Too bad I now need to re-pay shipping, local VAT and import duties on anything I get from Enertion to replace an item that should have worked from day one. Ah well, lessons learned…

1 Like