ESC not calibrating

Im using this ESC: Battery: 18650 pack worked on my ebike. 42v ~10ah motor: controller: (worked on my other esk8) Followed these instructions:

Problem: When i try to calibrate it i hold the set button down and turn it on and i let go of the set button when the red LED started blinking. I then pressed the set button again when my throttle was at neutral and no sound or green LED flash happened? Am i getting anything wrong. Idk what is wrong

Your battery is 10s. Your ESC can only handle 4s. Try it with a 4s battery :slight_smile:

1 Like

Just tried it with 4s and the same problem persists

is it lightning green?

if so:

First switch OFF the ESC, then connect it to the battery pack. Turn ON the transmitters(controller) and pull the throttle of the controller backwards end position(braking).

Then you hold the SET button on the ESC and switch it ON, wait 2 second for the GREEN LED to begin to flash and the motor make beep beep, then release the SET button and pull the throttle of your controll to neutral also just let the throttle go to middle. Then you will hear a continous beep sound and see a red Led blink continous. then click SET again and you will hear another beep!

Now drag your throttle trigger to the end of your front position of the controller and press the SET button one time and you will hear the motor beep beep.

Lastly push the throttle trigger to the end position of backward and press the SET button one time, and then you will hear beep beep beep. red and green will blink, then the throttle range calibration is done. the motor can be started after 2 seconds.

It beeps once and works for neutral but when i press full forward it doesnt beep at all. It just flashed the red LED really fast continuously and doesnt respond

When i press the set button on full throttle

Didnt you get a information thing on how to use it?

Just found out why. Im using a 10s battery on a 3s esc. Changed to 3s and it works now

1 Like