Eskating Dual Beast Cut Offs

Hey guys,

Quick question that I need some input on. I’ve had quiet a bit of issue with my eskating dual beast. Anyways recently I got it fixed by replacing the bms. After doing this the board worked flawlessly for 2-3 weeks. Whilst riding home from the station 2 weeks ago I noticed a sudden cut off, since then even the slighest harder acceleration/breaking results in the board cutting off.

Very strange type of cut off as well, some cut offs ive had in the past have permanently turned of the board, with this one the board keeps turned on but only the slighest of acceleration causes a cut off.

I’ve tried opening the enclosure to see if there is something that is burnt or likewise, no luck on that part.

One thing that I noticed whilst charging is that the board only charges to 50.1, not 50.4. Was that way ever since I got it fixed.

Anyone had similar issues that got some experience with this?

Cheers, Leonard

if you won’t void your warranty and you have multimeter, I would remove wrap from battery and check each individual group to see if any group is dead/under 3V. I had cut outs on one battery because bms killed one group.

btw, where do you check voltage? do you have display or with multimeter?

You could also very carefully check the groups from the balance plug.


That’s probably the best way - don’t have to remove any of the heat shrink - helps if your multi meter probes are extra pointy though :laughing:

1 Like

Dude, the “power turns off” was happening to me and it broke my leg. Sounds the same, depending on the version you have the power button can easily be turned off by small sticks/rocks, so if you run over one and it gets launched at the power button, the board turns its self off.

As for the more recent cutoffs, you probably have imbalanced cells if it was left at 100% charge while you didn’t repair it and the other cutoffs are an issue you need to investigate but I would suspect the battery again.

Seriously small stones hitting the power button? More than once? Get a lottery ticket right now.


Talk to eskating before you delve too deep into the issue because there will be a warranty and you don’t want to void that. There are a multitude of reasons why and without a complete breakdown of the set up it really can not be diagnosed.


The power switch is physically switched off, and it only happened to me when riding along quite smooth trails with small rocks/sticks. So not much else really could have happened, I certainly didn’t hit a large bump or anything.

I understand that that can happen but multiple times is very unlikely.

He has an issue and as yet its hard to discern

Hello i am building my first board with fsesc 4.12 and i have connected everything, do i have to connect the vesc to computer before it will work?

Yes. Your VESC Won’t know anything about the motor its attached too, and how to interpret the signals your remote is sending. You need to connect it to your computer, or if you have a bluetooth module, your phone, and go through the motor / remote setup wizards. Its super simple on the latest vesc tool, you just press a button and it will fill everything out for you.

Do you know about any vesc tool to Mac ?

Not the right thread…

Not the right thread but here you go anyway.

Dosent work i need a newer firmware…