Hi everyone, I’m very new to this so I’ll probably need to be walked through this, I first noticed that when I keep the throttle on, it cuts out and there’s a red light that flashes 4 times pauses and 4 times again. Here’s a video https://youtube.com/shorts/UbsmZ_r6Y-I The vesc I’m using is a mini 4.20

1 Like

What does this mean? @JgoFast

The Mini FSESC 4.20 can’t handle that much power. Try reducing battery max to 25A.

Lower “Duty Cycle Current Limit Start” to 85%.

Change the “Minimum erpm” and “maximum erpm” back to the factory defaults.

Try then. That may fix it, IDK.

The problem with Flipsky ESCs is that often, they are just bad and it’s not operator error. But we can try anyway. Flipsky ESCs are often a dice roll.

1 Like

Okay thanks but how do I know the factory erpm? Also yeah that’s what I heard wait flipskys unfortunately it sounds like a hot or miss sort of thing with these. Do you have any recommendations for a different Vesc that isn’t super expensive?

There is a button next to the setting that will recall the default.

1 Like

okay thanks, but I don’t think my vesc is designed to handle 100000erpm?

1 Like

It actually might, but either way you don’t want to cut brakes if you’re ever going down a hill that fast. You can set that to whatever you want. But I recommend leaving it at default.

So do you mean by setting it 60k it can possibly cut out while going downhill too fast? I think my max erpm is okay? cause I have a 120kv motor with a 10s set up so 42x120=5040x7=35280erpm. I think I’m starting to see what you mean cause this problem seems like it’s only occurring when there’s little to no load (me not riding it) on the motor making it go above the 120kv so that the ermp reaches over 60k, therefore, cutting out? Also for the reverse one, I’m assuming it’s for brakes and to reach over 60k erpm I’ll probably have to be going about 50+km. Not sure how fast you ride but as a beginner I’m not riding that fast yet plus I need to work on speed wobbles lol, I’m standing like a stick. That’s just my theory I’m probably not right though.

Leave those at the default, you’ll have no issues if you do that.

I’ll try this out and hopefully, it works.