Faulty 10S2P BMS? SOLVED!


I have a problem with my diy electric longboard. I have 10S2P batterypack that I built in it, and I’m using this BMS in it 10s2P BMS

I made this build a few months ago and haven’t ride with it much yet, but after my last ride the batterypack wont charge anymore. At first I suspected some wires had come loose because of all the vibration but that doesn’t seem to be the case because i checked all the connections. I have tried to charge it with another working charger but no luck so the problem isn’t in it. I have also measured the voltages in each cell through the BMS connector and the voltage is within 0.1V (can’t get more accurate reading). At the moment the battery is at 36.6V.

So I’m suspecting the problem is BMS, its almost new and should be a good quality so I have a bit hard time to believe that.

What do you think? Is there any more I can do to confirm it’s the BMS?

Okay guys, I SOLVED IT!

So, I got very frustated and decided to knock all over the BMS board with plastic pen while it was hooked on charger. And after a while I saw the charger indicator turn red!

I inspected the area where I was hitting with my pen and found that one of the legs of some component seemed to be loose. I tapped that component with my pen and yes one of the legs had a loose solder.

Thats a huge relief because now I know why it wasn’t charging and I can fix it with some solder.

It seems to be a pretty good idea to knock the board with something plastic, because you may end up finding the problem!! :grinning::sweat_smile:


Wouldn’t a hammer be more effective? :joy:

Well that just might be :rofl::laughing:

yeah those ebay bms came DOA for me. not the most reliable