Faulty ESC? Raging_Dwarf/homemade aluminum&hardwood handmolded shape deck/ retreaded 200w hub wheels/7S3p 6ah batteriepack made from metabo packs/generic esc

Hello guys, This is my first post here but been reading alot the last few weeks. As i was looking for a new means of transport i ended up buying a cheap chinese e-skateboard just to get arround untill i put a mountainboard together. And i know alot tend to look down on that chinese crap, but for me its more the challenge to turn crappy stuff into better quality by using whatever i can get my hands on. And i must say so far that crappy chinese board has turned into something pretty descent so far. Untill 2 days ago when i tried out my new batteriepack made from old metabo grinder packs. (Trying to fit an extra 7 batteries in the same case was a challenge but i succeeded😄and now have what might be the oddest batteriepack arround.) When i put my board together and tested it only one of the two motors works. I switched wires and the other motor is’t screwed so its something with the ESC… I have allready measured for continueity on the mosfets and that turned out fine. Also the 3 leds on the esc are working normally. Is there anything you guys know what i can do to make any further diagnose to determine where the problem sits? I not waiting for any" get a proper VESC" comment I allready have a 6.1 shipped but thats for the MB. Im just trying to get this one working again(soldering new compone’ts isnt an issue, i have my proper tools for that.

Wooww dude… it’s really hard to read when you don’t use a break between your sentences and paragraphs :wink:

Fault finding is a process of elimination, sounds like you already know this as you have swapped motors etc.

I would suggest you take time to trace all wires and check all connections. Make sure no hidden breakages or bad contacts.

Also, it never hurts to email directly to the original manufacturers, they might know something about their product that regular users don’t. Known faults with known fix.

1 Like

Yeah sorry about the break thing, i typed that on my phone and probably due to a bug in this site i can only see the first line. The rest is covered by my keyboard, so i was typing blind :stuck_out_tongue_closed_eyes: oh…and english isnt my native language, i speak dutch as im from belgium. that might also be a cause :sweat_smile: Anyway i have allready tried to find more info about the ESC but not even one hit on google :sob: Theres no case so the only details are printed on the 2 pcbs The top green pcb says : SZLY-01-3S5480-2.0V followed by: SZLY-20181122 (mostlikely the manuf. date) Then the white pcb below says: SZLY-01-20181123 (again the manuf. date???) followed by: SZLY-013S7080-1.3V again followed with: 94V-0 E346669 HD-1 You would think something would pop up but no direct hit on any of those codes.

The things i checked so far are: -fully charged battery pack AND remote -re-paired ESC and remote -swapped the wires from the motors and then the other wheel stops so both hubmotors are fine. -tried without sensor wires -measured for contuity between both pos. and neg connectors from the batterieleads to each of the 3 motor wires to see if none of the MOSFETs are fried. -on the upper green pcb you have 3 LEDs. One is for power and the two others are signal indicators that blink or light up on accelerate or brake signal. All these react as normal. -both the capacitors look normal. Also is it impossible to separate the two pcbs as they are soldered and glued shut. So if someone here has any more info or tips. Go nuts!!!

That happens to me sometimes… i feel your pain…

looks like you did some pretty thorough checks… There is a good chance the electronics are toast & need to be replaced.

Can you share a photo of the PCB?

i desoldered the top pcb and split them up. This is the bottom one. I checked the caps visually and measured them out by draining and then with the continuity settings voltage watched them recharging. All ok. Then proceeded to the fets. And as far as you can test an “in circuit” mosfet they seem to measure out as was stated on a tutorial on diagnosing mosfets. On the rest of the pcb all looked fine so i went to the top pcb. At the underside of that pcb i found another pair of fets as you see here. But as the first one seemed ok The second one encirceled in red does not read out as all the others. Where i should have a value of 900ohm i got 480 something. But i will remeasure again tonight. Might be that i didnt short gate and drain long enough.

The thing is when you connect the esc and apply power to it. All 3 leds do what they supposed to. When you turn the remotes acelleration they blink as they should, but then the led on the faulty side remains on so not blinking like the good side

Now a quick question on the side

In the picture you see the top pcb and its connectors. I written what each connector is used for. Only the two with the purple questionmarks i dont know. Doing some research i found some info but dont know the info is correct. The upper connector they said was a developer port. And the bottom would be for lights. So i wondered if the dev. Connector would be usable. Like maybe for firmware updates or so. Is there any way i could check if they usable?