Firmware update motor wont detect

for the last week i have been trying to get my dual 6374 motors on two enertion focboxs to connect with can bus but cannot using bldc tool from enertion website (which i got motor detection). so i tried ackmaniac tool. i updated my firmware as it told me it was too old. i am able to set everything up motor wise besides it will not detect either motor. i also cannot get the can bus to work what so ever either. ive ran both set up wizards for motor and input and still nothing. no clue how to figure this out. this is my first build and it is becoming very frustrating. if it helps im using a 12s5p battery as well. please any help would be much appreciated.

What tutorial did you use to set your Focboxes up ?

Did you remove the motor pulley and belt/chain before each launching motor detection in BLDC Tool ?

When you tried to set the 2 Focboxes up, have you powered only 1 focbox while the CAN bus was plugged to both Focboxes ?

I followed a video on YouTube of a guy setting up two hub motors. I did not keep can wire plugged in while configuring the motors settings using the setup wizard. No belts on the motor just the pulley. It’s so weird that it will spin and work but no detection. Motors fail hall sensor detection as well even when using the bldc tool that will detect the motors. So old firmware detects motors but not hall sensors. Newer doesn’t detect anything. There are no fault codes even after failing motor detection

@Slak is referring to when you did try to hook up canbus. If you have both FB hooked up via CAN and don’t power both Vescs at the same time, you can blow can chips… I believe.

Try this from @JohnnyMeduse

1 Like

I was using my battery to.power both at sane time. Never tried pwering one vesc at a time. I’ll give tat a go when I get off work and let ya know how it goes thanks

Just to clarify do NOT power the vescs individually if you have the Canbus cable connected.


If it wont detect and you have sensorless motor, you cud try raising the duty cycle i think is the d value next to the motor detect the default value is 0.05 raise it up.

There are couple good vids to show setting up can, best to check them out:


yeah i figured it would be bad to power them up seperatly which i never have or intend to do.

1 Like

i have maytech 6374 with sensor wires but i will try that thank you

Not sure if it will help for sensored, did you have the sensor cable connected when you tried to run the detection?

yes. i had everything but can wire plugged in while trying to get everything working. its so strange that the old firmware with a different bldc tool would detect the motors but with newer firmware would not. i will also post pics of my vesc settings if that will help

I was not there after the update, but before it the motors were detecting just fine. As for the CanBus issue, I tried using one of my spare focboxes on rexpeppers setup in place of each focbox and got the same issue with the Canbus not communicating. I’ve also tried rotating the master/slave vesc with no luck. Each motor works individually as the master, but no the salve just wont’ work. We thought it may be a janky cable, so he ordered a canbus cable from psychotiller.

i tried the new wires yesterday wallgreens and no luck which was what led me to try firmware update

What firmware are your boxes running now?

i reverted them back to 2.18 since the ackmaniac tool wasnt detecting the motors or sensors. i think it was 3.1 for firmware

are you trying in bldc or in FOC I had one motor that would get picked up in bldc on the bldc tool but not the other one. I tried bldc in Acks vesc tool and neither worked. Tried FOC and both motor and hall sensor were detected

ive was originally trying to set up in foc but have tried bldc as well with no success with ackmaniacs tool

this is the one i had used

@longhairedboy Any ideas or things to try on this one bro? I’m thinking of trying his vescs inside my board to try and isolate the problem, but you or Jake’s expert advice would be greatly appreciated.

It doesnt detect or you get the hall error 255?